summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-06-05 16:00:59 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-06-05 16:05:25 -0400
commit1a1fc80ba7e47494400019c924245aff51b8307e (patch)
treefc6a96e01e6393cc85f1d525d209f6b445e3a3d0 /app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
parentapp-office/skrooge: Drop 2.18.0 (diff)
downloadgentoo-1a1fc80ba7e47494400019c924245aff51b8307e.tar.gz
gentoo-1a1fc80ba7e47494400019c924245aff51b8307e.tar.bz2
gentoo-1a1fc80ba7e47494400019c924245aff51b8307e.zip
app-crypt/libu2f-host: bump to 1.1.10
Bug: https://bugs.gentoo.org/678580 Bug: https://bugs.gentoo.org/679724 Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild')
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
new file mode 100644
index 000000000000..74514141e2a9
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info udev user
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_linux static-libs systemd"
+
+DEPEND="dev-libs/hidapi
+ dev-libs/json-c:="
+RDEPEND="${DEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~HIDRAW"
+
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
+src_install() {
+ default
+ if use kernel_linux; then
+ udev_dorules 70-u2f.rules
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if ! use systemd; then
+ elog "Users must be a member of the 'plugdev' group"
+ elog "to be able to access U2F devices"
+ fi
+}