summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/md6sum/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/md6sum/files')
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-cflags.patch27
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-format-security.patch26
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-ldflags.patch12
3 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/md6sum/files/md6sum-1.0-cflags.patch b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
new file mode 100644
index 000000000000..18e1937c4424
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
@@ -0,0 +1,27 @@
+--- Makefile.in 2012-11-07 22:04:51.207982344 -0500
++++ Makefile.in.new 2012-11-07 22:06:00.905977580 -0500
+@@ -18,19 +18,19 @@
+ all: md6sum
+
+ md6sum: $(OBJS)
+- $(CC) $(OBJS) $(CXXFLAGS) $(LDFLAGS) -o $@
++ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) -o $@
+
+ md6_compress.o: md6_compress.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_mode.o: md6_mode.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_nist.o: md6_nist.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6sum.o: md6sum.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm *.o
diff --git a/app-crypt/md6sum/files/md6sum-1.0-format-security.patch b/app-crypt/md6sum/files/md6sum-1.0-format-security.patch
new file mode 100644
index 000000000000..061ec7b5f1b4
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-format-security.patch
@@ -0,0 +1,26 @@
+From 95833e409336bd0a4a656b7e2d0a9598dfe3f546 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 30 Aug 2014 21:25:23 +0300
+Subject: [PATCH] build: fix warning of format-security
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ md6sum.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/md6sum.c b/md6sum.c
+index 2401a5a..0338d30 100644
+--- a/md6sum.c
++++ b/md6sum.c
+@@ -428,7 +428,7 @@ void optd(char *optstr)
+
+ void opth()
+ { /* print md6sum help string */
+- printf(help_string);
++ printf("%s", help_string);
+ }
+
+ void optK(char *optstr)
+--
+1.8.5.5
+
diff --git a/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch b/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch
new file mode 100644
index 000000000000..23d37e192ea3
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Nru md6sum-1.0.orig/Makefile.in md6sum-1.0/Makefile.in
+--- md6sum-1.0.orig/Makefile.in 2011-01-09 02:12:09.000000000 +0000
++++ md6sum-1.0/Makefile.in 2011-02-01 04:41:35.000000000 +0000
+@@ -18,7 +18,7 @@
+ all: md6sum
+
+ md6sum: $(OBJS)
+- $(CC) $(OBJS) $(CXXFLAGS) -o $@
++ $(CC) $(OBJS) $(CXXFLAGS) $(LDFLAGS) -o $@
+
+ md6_compress.o: md6_compress.c inttypes.h md6.h md6_nist.h stdint.h
+ $(CC) $(CXXFLAGS) -c $< -o $@