summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/mdcrack/mdcrack-1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/mdcrack/mdcrack-1.2.ebuild')
-rw-r--r--app-crypt/mdcrack/mdcrack-1.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/mdcrack/mdcrack-1.2.ebuild b/app-crypt/mdcrack/mdcrack-1.2.ebuild
new file mode 100644
index 000000000000..5dcc0c486b44
--- /dev/null
+++ b/app-crypt/mdcrack/mdcrack-1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A MD4/MD5/NTML hashes bruteforcer"
+HOMEPAGE="http://mdcrack.df.ru/"
+SRC_URI="http://mdcrack.df.ru/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.diff \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-remove-interactive-test.diff
+
+ use ncurses || \
+ sed -i -e 's/^NCURSES/#NCURSES/g' \
+ -e 's/^LIBS/#LIBS/g' Makefile
+ sed -i -e '/^CFLAGS/d' \
+ -e 's|make bin/mdcrack|$(MAKE) bin/mdcrack|g' \
+ -e 's|make core|$(MAKE) core|g' Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" little || die "emake failed"
+}
+
+src_test() {
+ local failure=false
+
+ make CC="$(tc-getCC)" fulltest || die "self test failed"
+
+ for i in {1..20}; do
+ if grep "Collision found" out$i ; then
+ elog "Test $i: Passed"
+ else
+ elog "Test $i: Failed"
+ failure=true
+ fi
+ done
+
+ if $failure; then
+ die "Some tests failed"
+ fi
+}
+
+src_install() {
+ dobin bin/mdcrack || die "dobin failed"
+ dodoc BENCHMARKS CREDITS FAQ README TODO VERSIONS WWW || die
+}