summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-03-04 23:52:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-13 18:54:27 +0100
commit9044df347e794bc942b4e5b424eb5c81f83ff217 (patch)
tree3559f8ea3826cd7647ea75efff13369b1071a125 /app-crypt/moolticute
parentsys-devel/clang-runtime: Restore ~arm64 keywords, bug #650024 (diff)
downloadgentoo-9044df347e794bc942b4e5b424eb5c81f83ff217.tar.gz
gentoo-9044df347e794bc942b4e5b424eb5c81f83ff217.tar.bz2
gentoo-9044df347e794bc942b4e5b424eb5c81f83ff217.zip
app-crypt/moolticute: bump to 0.11.11_beta
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt/moolticute')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.11.11_beta.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index ffa42fddf8c6..f7b4c5557538 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
+DIST moolticute-0.11.11_beta.tar.gz 5363395 BLAKE2B 0d37c3af1fb79510a7203951d28426897ee6ed4ddf53d8ac84013ca1eb939a90b4ab6008a47a2d8974588dcc0fc7109e3a7e5770783c9312ed4335e14a016b18 SHA512 5b9fd72c52eec6755474a187dcd7af9ead89e2c08504d25ab6e4ab36991e032699cb8a9e02f402f7e5e551238bcfd225d2b5415945df07ec2bde7625c7041659
DIST moolticute-0.11.6_beta.tar.gz 5279167 BLAKE2B 4b93dbb038f75502907729398e7315397d5fd46fd7ee57214d5ea2f8dfdddd6c6d1e02242384ec8ca3a67a94711b7b3b68f28e4bb63cb24b224fcdfd75de1435 SHA512 5caf3ad6063da6d1761af37e52561b5834753abbc433e221b874788dd5c98782af8b4e723a78b2e849b8fe7cd0378e9304e5e93ac47e76d547dfc6b8ebe3c92a
diff --git a/app-crypt/moolticute/moolticute-0.11.11_beta.ebuild b/app-crypt/moolticute/moolticute-0.11.11_beta.ebuild
new file mode 100644
index 000000000000..b5153ad45a3e
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.11.11_beta.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}