summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-06-11 15:27:03 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-13 12:42:13 +0200
commitc6898f81d6cb6a0c64861a04741b9aabdcf88310 (patch)
treec73476fe4f5242d312b845dcfcb78db3042b04de /app-crypt/moolticute
parentmedia-libs/imlib2: remove -9999 (diff)
downloadgentoo-c6898f81d6cb6a0c64861a04741b9aabdcf88310.tar.gz
gentoo-c6898f81d6cb6a0c64861a04741b9aabdcf88310.tar.bz2
gentoo-c6898f81d6cb6a0c64861a04741b9aabdcf88310.zip
app-crypt/moolticute: bump to 0.18.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-crypt/moolticute')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.18.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 01119df6f68a..f88a43269230 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
DIST moolticute-0.12.9.tar.gz 5364306 BLAKE2B adf101a779d4a7dc801f9d7705e6d6b624fb380a502a0fadf38463045af38d7d3a0a2005d1617f9d5874349b347b39632ccbb89f9edb97f7f74f62a7fd129220 SHA512 c02542f3bc3db4740e981cdec8ffb753189b15a341e55812de0f0592e23a678a1be73167d6fa5ca32e943d9cdf5f4937abe8132332b490104beed82d5b8d24a7
+DIST moolticute-0.18.1.tar.gz 5549370 BLAKE2B 11a1a40e799e54f18e44eacb6ded1892681932676328bfcf0dfc23d197fc418bbe5b726adee280125e974bdf0497e9148f60735e0f80785380ae1b2894d1b187 SHA512 166c2091e84bbe19fced593c97f195d958feb37556670a1e457a0532bf4df399dce214e89782cb8006db5eedad5b9d2c21e5dc9902137f5b2b17b96aa6780366
diff --git a/app-crypt/moolticute/moolticute-0.18.1.ebuild b/app-crypt/moolticute/moolticute-0.18.1.ebuild
new file mode 100644
index 000000000000..da3da6c6597f
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.18.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}