summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-11 11:40:46 +0100
committerDavid Seifert <soap@gentoo.org>2018-03-11 11:40:46 +0100
commit0adc4a25a29c8c6b21890a59827015e84d90284f (patch)
treea3475e80f95c387613e9a3e5bdb1df80d76463d4 /app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
parentapp-crypt/libnitrokey: Initial addition (diff)
downloadgentoo-0adc4a25a29c8c6b21890a59827015e84d90284f.tar.gz
gentoo-0adc4a25a29c8c6b21890a59827015e84d90284f.tar.bz2
gentoo-0adc4a25a29c8c6b21890a59827015e84d90284f.zip
app-crypt/nitrokey-app: Add live ebuild
Bug: https://bugs.gentoo.org/634474 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-crypt/nitrokey-app/nitrokey-app-9999.ebuild')
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild b/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
new file mode 100644
index 000000000000..deb598f36ae3
--- /dev/null
+++ b/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="Cross platform personalization tool for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/nitrokey-app"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/libnitrokey:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"