summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/pdfcrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/pdfcrack')
-rw-r--r--app-crypt/pdfcrack/Manifest2
-rw-r--r--app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch22
-rw-r--r--app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch8
-rw-r--r--app-crypt/pdfcrack/metadata.xml8
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.13.ebuild28
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.14.ebuild28
6 files changed, 96 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/Manifest b/app-crypt/pdfcrack/Manifest
new file mode 100644
index 000000000000..6e46f19b199e
--- /dev/null
+++ b/app-crypt/pdfcrack/Manifest
@@ -0,0 +1,2 @@
+DIST pdfcrack-0.13.tar.gz 32359 SHA256 2afce56766bfbe869cb6d920ca0c9acf23d73872924bb62e2f4eb47bb43c96e8 SHA512 3ec993746649649ab5ddffdf6ae15d087ba6b52bbf3379bb022f33078968f1434788e5f3e6078a4342410094acfc022d5955faee0a35be878516908356513d35 WHIRLPOOL 0b98ec8ce74e2dbd6879c30f28bb79daa0f6e9f4254bdf291086ace9d65039ef9d3dc0c5304d0334aec7249476e4bf21365059999d7caac9e2f19929d0ab0be4
+DIST pdfcrack-0.14.tar.gz 33387 SHA256 ac88eca576cebb40c4a63cd90542664de7d8f1b39885db5a7ac021d8b0c6a95c SHA512 2da2b7bc37db49f55c6cdd45f837bc509b217fcd36cd57212c2508618996038e21bf391a20f5adece312e9a5f7d892fe254dac8438222f158e4ce7019cbac3f2 WHIRLPOOL 4d8fd5052bc165e3f058856a814832b010d1b2ce7fc6c630b04e797bff5658a784e7fb096d68792ce54282d0a4ace9d03a6458b85820f92b8e88215d461393a4
diff --git a/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch b/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch
new file mode 100644
index 000000000000..5f39e2695fec
--- /dev/null
+++ b/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch
@@ -0,0 +1,22 @@
+just use implicit rules so correct variables get used
+
+--- pdfcrack-0.13/Makefile
++++ pdfcrack-0.13/Makefile
+@@ -1,16 +1,11 @@
+-CFLAGS= -Wall -Wextra -O3 -g
++CFLAGS+= -Wall -Wextra
+
+ all: pdfcrack
+
+ pdfcrack: main.o sha256.o rc4.o md5.o pdfcrack.o pdfparser.o passwords.o common.o \
+ benchmark.o
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+
+
+ pdfreader: pdfparser.o pdfreader.o common.o
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+
+
+ clean:
+ rm -f pdfcrack pdfreader testreader *.o
+-
+-%.o: %.c
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $+
diff --git a/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch b/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch
new file mode 100644
index 000000000000..7ea168878d1e
--- /dev/null
+++ b/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch
@@ -0,0 +1,8 @@
+--- pdfcrack-0.14/Makefile
++++ pdfcrack-0.14/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -Wall -Wextra -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -O3 -g
++CFLAGS += -Wall -Wextra -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
+
+ all: pdfcrack
+
diff --git a/app-crypt/pdfcrack/metadata.xml b/app-crypt/pdfcrack/metadata.xml
new file mode 100644
index 000000000000..d810cd613bf3
--- /dev/null
+++ b/app-crypt/pdfcrack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <upstream>
+ <remote-id type="sourceforge">pdfcrack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/pdfcrack/pdfcrack-0.13.ebuild b/app-crypt/pdfcrack/pdfcrack-0.13.ebuild
new file mode 100644
index 000000000000..c4b086e972ab
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}
diff --git a/app-crypt/pdfcrack/pdfcrack-0.14.ebuild b/app-crypt/pdfcrack/pdfcrack-0.14.ebuild
new file mode 100644
index 000000000000..44836e8fbf0c
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}