summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/pgpdump/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/pgpdump/files')
-rw-r--r--app-crypt/pgpdump/files/pgpdump-0.28-respect-ldflags.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/pgpdump/files/pgpdump-0.28-respect-ldflags.patch b/app-crypt/pgpdump/files/pgpdump-0.28-respect-ldflags.patch
new file mode 100644
index 000000000000..1e0f0c6f266c
--- /dev/null
+++ b/app-crypt/pgpdump/files/pgpdump-0.28-respect-ldflags.patch
@@ -0,0 +1,42 @@
+From 087f54f29dd679a9c6eb5cce075d9f4c6ccbc57f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <mrueg@rueg.eu>
+Date: Sun, 11 Aug 2013 00:42:06 +0200
+Subject: [PATCH] Respect LDFLAGS, minor other improvements
+
+---
+ Makefile.in | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a0269a3..d174393 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -3,7 +3,8 @@ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ mandir = @mandir@
+ LIBS = @LIBS@
+-CFLAGS = @CFLAGS@ -O -Wall
++CC = @CC@
++CFLAGS = @CFLAGS@ -Wall
+ LDFLAGS = @LDFLAGS@
+ VERSION = `git tag | tail -1 | sed -e 's/v//'`
+
+@@ -22,13 +23,13 @@ MAN = pgpdump.1
+ CNF = config.h config.status config.cache config.log
+ MKF = Makefile
+
+-.c.o:
++%.o : %.c
+ $(CC) -c $(CFLAGS) $<
+
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(CFLAGS) -o $(PROG) $(OBJS) $(LIBS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(PROG) $(OBJS) $(LIBS)
+
+ clean:
+ $(RM) $(OBJS) $(PROG)
+--
+1.8.1.6
+