summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-12-10 10:33:19 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-12-11 00:36:22 +0200
commit8ca90ec5a4bfdeb32c7d70f31d14c41d88204b4f (patch)
tree192c7663dae54ec528b3724a78f5f17075c89ed9 /app-crypt/pinentry
parentwww-plugins/chrome-binary-plugins: automated update (57.0.2946.0) (diff)
downloadgentoo-8ca90ec5a4bfdeb32c7d70f31d14c41d88204b4f.tar.gz
gentoo-8ca90ec5a4bfdeb32c7d70f31d14c41d88204b4f.tar.bz2
gentoo-8ca90ec5a4bfdeb32c7d70f31d14c41d88204b4f.zip
app-crypt/pinentry: simplify MOC a bit
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/pinentry-1.0.0.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/app-crypt/pinentry/pinentry-1.0.0.ebuild b/app-crypt/pinentry/pinentry-1.0.0.ebuild
index 2106259c4232..55953287ea1f 100644
--- a/app-crypt/pinentry/pinentry-1.0.0.ebuild
+++ b/app-crypt/pinentry/pinentry-1.0.0.ebuild
@@ -70,17 +70,16 @@ src_configure() {
use static && append-ldflags -static
[[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
- QT_MOC=""
if use qt4; then
- myconf+=( --enable-pinentry-qt
- --disable-pinentry-qt5
- )
- QT_MOC="$(qt4_get_bindir)"/moc
- # Issues finding qt on multilib systems
+ myconf+=(
+ --enable-pinentry-qt
+ --disable-pinentry-qt5
+ )
+ export MOC="$(qt4_get_bindir)"/moc
export QTLIB="$(qt4_get_libdir)"
elif use qt5; then
myconf+=( --enable-pinentry-qt )
- QT_MOC="$(qt5_get_bindir)"/moc
+ export MOC="$(qt5_get_bindir)"/moc
export QTLIB="$(qt5_get_libdir)"
else
myconf+=( --disable-pinentry-qt )
@@ -95,8 +94,7 @@ src_configure() {
$(use_with caps libcap) \
$(use_enable gnome-keyring libsecret) \
$(use_enable gnome-keyring pinentry-gnome3) \
- "${myconf[@]}" \
- MOC="${QT_MOC}"
+ "${myconf[@]}"
}
src_install() {