summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/qca/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/qca/files')
-rw-r--r--app-crypt/qca/files/qca-2.0.2-pcfilespath.patch13
-rw-r--r--app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch59
-rw-r--r--app-crypt/qca/files/qca-2.1.0.3-qt55.patch26
-rw-r--r--app-crypt/qca/files/qca-disable-pgp-test.patch13
4 files changed, 111 insertions, 0 deletions
diff --git a/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch b/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch
new file mode 100644
index 000000000000..c52e8e78071b
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch
@@ -0,0 +1,13 @@
+Index: qca-2.0.2/configure
+===================================================================
+--- qca-2.0.2.orig/configure
++++ qca-2.0.2/configure
+@@ -937,7 +937,7 @@ public:
+ if(!pcfiles.isEmpty())
+ {
+ str = QString(
+- "pcfiles.path = \$\$LIBDIR/pkgconfig\n"
++ "pcfiles.path = \$\$LIBDIR/../pkgconfig\n"
+ "pcfiles.files = %1\n"
+ "INSTALLS += pcfiles\n"
+ ).arg(pcfiles.join(" "));
diff --git a/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch b/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch
new file mode 100644
index 000000000000..1752dff910ff
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch
@@ -0,0 +1,59 @@
+--- trunk/kdesupport/qca/src/botantools/botan/botan/secmem.h 2012/01/14 16:09:19 1273507
++++ trunk/kdesupport/qca/src/botantools/botan/botan/secmem.h 2012/01/14 17:12:15 1273508
+@@ -191,15 +191,15 @@
+ {
+ public:
+ MemoryVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ MemoryVector(u32bit n = 0) { MemoryRegion<T>::init(false, n); }
+ MemoryVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(false); set(in, n); }
++ { MemoryRegion<T>::init(false); this->set(in, n); }
+ MemoryVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(false); set(in); }
++ { MemoryRegion<T>::init(false); this->set(in); }
+ MemoryVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(false); set(in1); append(in2); }
++ { MemoryRegion<T>::init(false); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -210,15 +210,15 @@
+ {
+ public:
+ SecureVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
+ SecureVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(true); set(in, n); }
++ { MemoryRegion<T>::init(true); this->set(in, n); }
+ SecureVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(true); set(in); }
++ { MemoryRegion<T>::init(true); this->set(in); }
+ SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(true); set(in1); append(in2); }
++ { MemoryRegion<T>::init(true); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -229,14 +229,14 @@
+ {
+ public:
+ SecureBuffer<T,L>& operator=(const SecureBuffer<T,L>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureBuffer() { MemoryRegion<T>::init(true, L); }
+ SecureBuffer(const T in[], u32bit n)
+ { MemoryRegion<T>::init(true, L); copy(in, n); }
+ private:
+ SecureBuffer<T, L>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+ };
+
+ }
diff --git a/app-crypt/qca/files/qca-2.1.0.3-qt55.patch b/app-crypt/qca/files/qca-2.1.0.3-qt55.patch
new file mode 100644
index 000000000000..277c24e02800
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.1.0.3-qt55.patch
@@ -0,0 +1,26 @@
+From 7207e6285e932044cd66d49d0dc484666cfb0092 Mon Sep 17 00:00:00 2001
+From: Hrvoje Senjan <hrvoje.senjan@gmail.com>
+Date: Sat, 17 Jan 2015 20:12:18 +0100
+Subject: [PATCH] Add missing QIODevice include
+
+Fixes build with Qt 5.5
+---
+ include/QtCrypto/qca_basic.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/QtCrypto/qca_basic.h b/include/QtCrypto/qca_basic.h
+index 42808c5..e0c6cbb 100644
+--- a/include/QtCrypto/qca_basic.h
++++ b/include/QtCrypto/qca_basic.h
+@@ -35,6 +35,8 @@
+
+ #include "qca_core.h"
+
++#include <QIODevice>
++
+ // Qt5 comes with QStringLiteral for wrapping string literals, which Qt4 does
+ // not have. It is needed if the headers are built with QT_NO_CAST_FROM_ASCII.
+ // Defining it here as QString::fromUtf8 for convenience.
+--
+2.0.5
+
diff --git a/app-crypt/qca/files/qca-disable-pgp-test.patch b/app-crypt/qca/files/qca-disable-pgp-test.patch
new file mode 100644
index 000000000000..7944e3c358ea
--- /dev/null
+++ b/app-crypt/qca/files/qca-disable-pgp-test.patch
@@ -0,0 +1,13 @@
+diff --git a/unittest/CMakeLists.txt b/unittest/CMakeLists.txt
+index f4d9eb9..67ef281 100644
+--- a/unittest/CMakeLists.txt
++++ b/unittest/CMakeLists.txt
+@@ -23,7 +23,7 @@ add_subdirectory(keylengthunittest)
+ add_subdirectory(keystore)
+ add_subdirectory(macunittest)
+ add_subdirectory(metatype)
+-add_subdirectory(pgpunittest)
++# add_subdirectory(pgpunittest)
+ add_subdirectory(pipeunittest)
+ add_subdirectory(pkits)
+ add_subdirectory(rsaunittest)