summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-07 18:13:45 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-07 18:16:29 +0200
commit054081659d643ab536a426959ea3de9262514bf1 (patch)
tree17b6f92b9edf8d39f1407ffaaf758f7c20009955 /app-crypt/rainbowcrack
parentnet-libs/libwebsockets: drop 4.1.1 (diff)
downloadgentoo-054081659d643ab536a426959ea3de9262514bf1.tar.gz
gentoo-054081659d643ab536a426959ea3de9262514bf1.tar.bz2
gentoo-054081659d643ab536a426959ea3de9262514bf1.zip
app-crypt/rainbowcrack: bump to 1.8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt/rainbowcrack')
-rw-r--r--app-crypt/rainbowcrack/Manifest1
-rw-r--r--app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/rainbowcrack/Manifest b/app-crypt/rainbowcrack/Manifest
index d5245f6c9e58..7877552ca0b9 100644
--- a/app-crypt/rainbowcrack/Manifest
+++ b/app-crypt/rainbowcrack/Manifest
@@ -1 +1,2 @@
DIST rainbowcrack-1.7-linux64.zip 208726 BLAKE2B 842e0a3ee74a8576a5331cc86259178b382e82f465f3093e7d1fa1b44907c1c30a73f53c2f7f527e052bc6266ceffd350c42b9b80b1298072a02c0cbd25e660d SHA512 068fe9d31004e08c0fcbe5a11500bd6248eca2f204a8d99a7343824ebc1dd847a01eb459f28d77fdd84eae98b05169a69e10b8893b9b5dd027381965c19b7bdb
+DIST rainbowcrack-1.8-linux64.zip 220109 BLAKE2B 164894ccb07490756a0c9b297b1497d6305fade66b31fd712914261219dd957632cd285ab2e7ad7a683dd3c0a425eb1969676ea23136abf7d688fcde9e445e74 SHA512 84dbf3431605fb5dcc8e7cd305a43e9b239ebd6e5ef120edd951a3180c38498fe3a26157e3b55d114c6630f8ac1382a610d8e6230779c5b12cbc42c04e9aff57
diff --git a/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild b/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild
new file mode 100644
index 000000000000..7a4aba0ea140
--- /dev/null
+++ b/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit wrapper
+
+DESCRIPTION="Hash cracker that precomputes plaintext - ciphertext pairs in advance"
+HOMEPAGE="https://project-rainbowcrack.com/"
+SRC_URI="https://project-${PN}.com/${P}-linux64.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror" #444426
+
+RAINBOW_DESTDIR="opt/${PN}"
+
+QA_FLAGS_IGNORED="${RAINBOW_DESTDIR}/.*"
+QA_PRESTRIPPED="${RAINBOW_DESTDIR}/.*"
+
+DEPEND="app-arch/unzip"
+
+DOCS=(
+ readme.txt
+)
+
+S="${WORKDIR}"/${P}-linux64
+
+# rainbowcrack-1.8 zipfiles, including the ones for Linux, use backslashes as path separators.
+# unzip handles it just fine but produces a warning, the side effect of which is that it exits
+# with code 1 rather than 0.
+# Don't bother with iterating over A, we already assume the file to be a .zip so we might as well
+# assume there is only one.
+src_unpack() {
+ unzip -qo "${DISTDIR}/${A}"
+ local unzip_retval="${?}"
+ case "${unzip_retval}" in
+ 0|1)
+ ;;
+ *)
+ die "Failed to unpack the source archive"
+ ;;
+ esac
+}
+
+src_install() {
+ einstalldocs
+
+ local bin bins="
+ rcrack
+ rt2rtc
+ rtc2rt
+ rtgen
+ rtmerge
+ rtsort
+ "
+
+ exeinto "/${RAINBOW_DESTDIR}"
+ doexe alglib0.so ${bins}
+
+ for bin in ${bins}; do
+ make_wrapper ${bin} ./${bin} "/${RAINBOW_DESTDIR}" "/${RAINBOW_DESTDIR}"
+ done
+
+ insinto "/${RAINBOW_DESTDIR}"
+ doins charset.txt
+}