summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2020-04-15 03:00:40 +0200
committerJonas Stein <jstein@gentoo.org>2020-04-15 03:01:36 +0200
commitbee1d6e7dce96fc0e85e1274f954a82461423242 (patch)
tree8302461875d9d58d47e1ffa67216a30b0660704a /app-crypt/rotix
parentsys-firmware/broadcom-bt-firmware: New package (diff)
downloadgentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.tar.gz
gentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.tar.bz2
gentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.zip
app-crypt/rotix: bump EAPI=7
bump EAPI=7 update SRC_URI Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-crypt/rotix')
-rw-r--r--app-crypt/rotix/Manifest1
-rw-r--r--app-crypt/rotix/files/rotix-0.83-locale.patch10
-rw-r--r--app-crypt/rotix/rotix-0.83-r1.ebuild34
3 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/rotix/Manifest b/app-crypt/rotix/Manifest
index 01106d42a19b..3faffe2397cd 100644
--- a/app-crypt/rotix/Manifest
+++ b/app-crypt/rotix/Manifest
@@ -1 +1,2 @@
DIST rotix-0.83.tar.bz2 14685 BLAKE2B 296e094dfef2b35db39041e92d350befc970f3594c7aa2962b4dba0215e99b50ea887d3d636dc2e38ee570b60462bcf8304a6f7ee005315fa115b821ee0f29ad SHA512 1f318e15bd51cc197d9d9fc36e37b29c18fe7a8e8c40654c69ccf97d32b896afa7cc517c562750f6c1262baddbb451bd8a29ada994176e442630d8ed56ccf572
+DIST rotix-0.83.tar.gz 15412 BLAKE2B 4a0db309fa23af3e15a63263e40a2b27e2ebf1e0cf162f2776ebd5237621207eee3a41374170c2e0441104704bde4aff8f929fc5ad8994dfcf4fd1cb5a461696 SHA512 bffe527714f35a99f3322e87d1e2fcbafd38f3a7677e2ca816988df2ce1567ce064f0ab7a543fab3dc2d73f148675fe069c398a5d9c7bb285cb6b1658c3fbffb
diff --git a/app-crypt/rotix/files/rotix-0.83-locale.patch b/app-crypt/rotix/files/rotix-0.83-locale.patch
new file mode 100644
index 000000000000..460a75da9a48
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-locale.patch
@@ -0,0 +1,10 @@
+--- rotix-0.83.orig/rotix.c
++++ rotix-0.83/rotix.c
+@@ -38,6 +38,7 @@
+ /* I18N */
+ #ifdef I18N
+ #include <libintl.h>
++#include <locale.h>
+ #define _(String) gettext (String)
+ #else
+ #define _(String) String
diff --git a/app-crypt/rotix/rotix-0.83-r1.ebuild b/app-crypt/rotix/rotix-0.83-r1.ebuild
new file mode 100644
index 000000000000..659781528a35
--- /dev/null
+++ b/app-crypt/rotix/rotix-0.83-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Rotix allows you to generate rotational obfuscations"
+HOMEPAGE="https://github.com/shemminga/rotix"
+SRC_URI="https://github.com/shemminga/${PN}/releases/download/${PV}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.83-respect-CFLAGS-and-dont-strip.patch
+"${FILESDIR}"/rotix-0.83-locale.patch
+"${FILESDIR}"/rotix-0.83-interix.patch )
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ use elibc_glibc || append-flags -lintl
+ econf --i18n=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}