summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-20 12:55:45 -0400
committerMike Gilbert <floppym@gentoo.org>2021-10-20 12:55:45 -0400
commitbd7d7208554b9ae9a1416f46512a6ac4b7f08caa (patch)
tree1f45298b56d737e52e83a254c2f46b75fe2a72f8 /app-crypt/stoken
parentdev-qt/qtwebengine: Drop 5.15.2_p20211015 w/o keywords (diff)
downloadgentoo-bd7d7208554b9ae9a1416f46512a6ac4b7f08caa.tar.gz
gentoo-bd7d7208554b9ae9a1416f46512a6ac4b7f08caa.tar.bz2
gentoo-bd7d7208554b9ae9a1416f46512a6ac4b7f08caa.zip
app-crypt/stoken: fix automagic dep on libtomcrypt
Also rename 'static' to 'static-libs'. Also drop libstoken.la. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/stoken-0.92-r2.ebuild (renamed from app-crypt/stoken/stoken-0.92-r1.ebuild)19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-crypt/stoken/stoken-0.92-r1.ebuild b/app-crypt/stoken/stoken-0.92-r2.ebuild
index 2508df6bacdf..9cf7d5d6aeb7 100644
--- a/app-crypt/stoken/stoken-0.92-r1.ebuild
+++ b/app-crypt/stoken/stoken-0.92-r2.ebuild
@@ -12,19 +12,30 @@ SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86"
-IUSE="gtk static"
+IUSE="gtk static-libs"
-# || ( dev-libs/nettle dev-libs/libtomcrypt ) libtomcrypt is not packaged
+# TODO: add a USE flag to enable optional use of tomcrypt instead of nettle.
RDEPEND="
dev-libs/nettle
gtk? ( >=x11-libs/gtk+-3.12:3 )"
DEPEND="${RDEPEND}"
src_prepare() {
+ default
eautoreconf
- eapply_user
}
src_configure() {
- econf $(use_with gtk) --enable-static=$(usex static)
+ local myconf=(
+ $(use_with gtk)
+ $(use_enable static-libs static)
+ --with-nettle
+ --without-tomcrypt
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
}