summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-12-18 20:56:00 -0600
committerJoonas Niilola <juippis@gentoo.org>2021-01-20 16:13:40 +0200
commit285ff66c5ae45705faa8d171a24afa4c8fba06e2 (patch)
tree1d6c84285cc7362b8485bda204975ec226de1bfd /app-crypt/tpm2-tools
parentapp-crypt/tpm2-tools: Fix libressl support (diff)
downloadgentoo-285ff66c5ae45705faa8d171a24afa4c8fba06e2.tar.gz
gentoo-285ff66c5ae45705faa8d171a24afa4c8fba06e2.tar.bz2
gentoo-285ff66c5ae45705faa8d171a24afa4c8fba06e2.zip
app-crypt/tpm2-tools: Don't let configure run git, add missing dep
Closes: https://bugs.gentoo.org/760567 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tools')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild
new file mode 100644
index 000000000000..c03f468e3955
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi libressl"
+
+# Integration test are now run as part of the testing suite, which will fail
+# because none of the supported TPM emulators are in Portage. In a future
+# version of tpm2-tools, swtpm will be supported and the tests can be run.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl:=
+ >=app-crypt/tpm2-tss-3.0.1:=[fapi?]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/autoconf-archive"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.1-libressl.patch"
+ "${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ sed -i \
+ "s/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/" \
+ "${S}/configure.ac" || die
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ $(use_enable !libressl hardening)
+}