summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-12-19 17:42:33 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-19 17:48:27 -0500
commit203783d176b8f801bd640c5c1eaa372b6ea29e3e (patch)
tree01f9ee3ecdd9409453d34bda7d95a075669dd2e3 /app-crypt/veracrypt
parentdev-scheme/guile-gcrypt: bump up to 0.2.1 (diff)
downloadgentoo-203783d176b8f801bd640c5c1eaa372b6ea29e3e.tar.gz
gentoo-203783d176b8f801bd640c5c1eaa372b6ea29e3e.tar.bz2
gentoo-203783d176b8f801bd640c5c1eaa372b6ea29e3e.zip
app-crypt/veracrypt: bump to 1.24-Update2
Bug: https://bugs.gentoo.org/703340 Closes: https://bugs.gentoo.org/698936 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/veracrypt')
-rw-r--r--app-crypt/veracrypt/Manifest1
-rw-r--r--app-crypt/veracrypt/files/veracrypt-1.24_p2-revert-wxwidgets-breakage.patch100
-rw-r--r--app-crypt/veracrypt/veracrypt-1.24_p2.ebuild120
3 files changed, 221 insertions, 0 deletions
diff --git a/app-crypt/veracrypt/Manifest b/app-crypt/veracrypt/Manifest
index 15dd13cdf1e7..a96fc6991a00 100644
--- a/app-crypt/veracrypt/Manifest
+++ b/app-crypt/veracrypt/Manifest
@@ -1,3 +1,4 @@
DIST VeraCrypt_1.23.tar.gz 24941166 BLAKE2B f9760342678f771192434f88a9b6c3bcc348ef312197232346731f51e972c230a4627f92fd655f7a3c7582b1f728274b7f170f885cceadce6ad53c9b404cd8d6 SHA512 433e717403560fc4f9081f528168f346ed7f14f9621b78a176c6801f14caba3d57e3228b940fb746637de29893f278ade650cf5eca63490bc236987a9db4d48d
DIST VeraCrypt_1.24.tar.gz 25046467 BLAKE2B e8535f981d898efd797ff736a03e4a65b75bd40ed62d75e3f159932e93d9684e8601da277839b40efcd9bdda801427468386f37e9c57cd81dbc470f23693cd12 SHA512 b4a3155ec8455c51044c2aabcc785a6974d9ee740e0c77bae934a017976e715d45701811405dadfbbd9ceb2a957acbefbe15a717003c86ea38d52735de4f2e56
DIST veracrypt-1.24_p1.tar.gz 25052008 BLAKE2B 215af344a5e57e16319d6aec5f439517f774ee92b11d11060e98708d2e5390b54965eecda55bdc56e8e5f01a945b6782a8b695f24a747dd4e7ff2346b9af96e9 SHA512 2564c6b579bc3609d93fb3e6ec12c0e9e90b6b423ce06dab8870583d6b6ce0da9d864d64da67f4d1d6096e4dd750d335c66c0eed9199ec1b38c0690090f317a6
+DIST veracrypt-1.24_p2.tar.gz 25208374 BLAKE2B 2667fb93e6884d97a673fe793b5f83f73961c2362e7704199b5ed0163c03f19313843583f7f2a15e05ee71516e45db97752350d2c27d22f1f278668b7c07aff9 SHA512 f778b8f6288f6f9886a15fa582f6c7126d9eaea319e854ad11bd5d44105ad5a3cb8b750d410ed8fd531ec3b23f9bad83934e6cefedd1352603d4882d2ca0ad84
diff --git a/app-crypt/veracrypt/files/veracrypt-1.24_p2-revert-wxwidgets-breakage.patch b/app-crypt/veracrypt/files/veracrypt-1.24_p2-revert-wxwidgets-breakage.patch
new file mode 100644
index 000000000000..029b683e7d62
--- /dev/null
+++ b/app-crypt/veracrypt/files/veracrypt-1.24_p2-revert-wxwidgets-breakage.patch
@@ -0,0 +1,100 @@
+From 6ab07ac9a30fe48839e31f9c374fd6a6ddeeb382 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
+Date: Thu, 19 Dec 2019 17:04:37 -0500
+Subject: [PATCH] Revert "Linux: Fix failure to run VeraCrypt binary built for
+ console mode on headless machines (fix issue
+ https://github.com/veracrypt/VeraCrypt/issues/531)"
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The build failure still exists for system wxGTK compiled with '--disable-gui':
+
+```
+In file included from TextUserInterface.cpp:27:
+TextUserInterface.h: In member function ‘virtual bool VeraCrypt::TextUserInterface::Initialize(int&, wxChar**)’:
+TextUserInterface.h:50:63: error: ‘wxAppBase’ has not been declared
+ 50 | virtual bool Initialize (int &argc, wxChar **argv) { return wxAppBase::Initialize(argc, argv); }
+```
+
+This reverts commit 737e1f126b8826ed02418266e590e195aebdd7c0.
+---
+ src/Main/TextUserInterface.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/Main/TextUserInterface.h b/src/Main/TextUserInterface.h
+index 95db02d7..78874b8c 100644
+--- a/src/Main/TextUserInterface.h
++++ b/src/Main/TextUserInterface.h
+@@ -47,7 +47,9 @@ namespace VeraCrypt
+ virtual void ExportSecurityTokenKeyfile () const;
+ virtual shared_ptr <GetStringFunctor> GetAdminPasswordRequestHandler ();
+ virtual void ImportSecurityTokenKeyfiles () const;
++#ifndef TC_NO_GUI
+ virtual bool Initialize (int &argc, wxChar **argv) { return wxAppBase::Initialize(argc, argv); }
++#endif
+ virtual void InitSecurityTokenLibrary () const;
+ virtual void ListSecurityTokenKeyfiles () const;
+ virtual VolumeInfoList MountAllDeviceHostedVolumes (MountOptions &options) const;
+--
+2.24.0
+
+From d168eadc536552fbf76fe86c8ad0fa77130081e1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
+Date: Thu, 19 Dec 2019 17:15:43 -0500
+Subject: [PATCH] Revert "Linux: fix compilation error when building
+ console-only version of VeraCrypt that is statically linked to wxWidgets"
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The build failure still exists for system wxGTK compiled with '--disable-gui':
+
+```
+In file included from TextUserInterface.cpp:27:
+TextUserInterface.h: In member function ‘virtual bool VeraCrypt::TextUserInterface::Initialize(int&, wxChar**)’:
+TextUserInterface.h:50:63: error: ‘wxAppBase’ has not been declared
+ 50 | virtual bool Initialize (int &argc, wxChar **argv) { return wxAppBase::Initialize(argc, argv); }
+```
+
+This reverts commit 14bee5e6a227701e78c5fec04064c0494f6361f0.
+---
+ src/Main/Main.make | 8 ++++++++
+ src/Makefile | 1 +
+ 2 files changed, 9 insertions(+)
+
+diff --git a/src/Main/Main.make b/src/Main/Main.make
+index 0cb4e15d..a154a846 100755
+--- a/src/Main/Main.make
++++ b/src/Main/Main.make
+@@ -81,7 +81,15 @@ CXXFLAGS += -I$(BASE_DIR)/Main
+
+ #------ wxWidgets configuration ------
+
++ifdef TC_NO_GUI
++ifdef VC_WX_STATIC
++WX_CONFIG_LIBS := base
++else
++WX_CONFIG_LIBS := adv,core,base
++endif
++else
+ WX_CONFIG_LIBS := adv,core,base
++endif
+
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+
+diff --git a/src/Makefile b/src/Makefile
+index 1b084421..f102a28c 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -70,6 +70,7 @@ endif
+ ifeq "$(origin NOGUI)" "command line"
+ export TC_NO_GUI := 1
+ C_CXX_FLAGS += -DTC_NO_GUI
++ WX_CONFIGURE_FLAGS += --disable-gui
+ endif
+
+ ifdef PKCS11_INC
+--
+2.24.0
+
diff --git a/app-crypt/veracrypt/veracrypt-1.24_p2.ebuild b/app-crypt/veracrypt/veracrypt-1.24_p2.ebuild
new file mode 100644
index 000000000000..4dd97395b9d6
--- /dev/null
+++ b/app-crypt/veracrypt/veracrypt-1.24_p2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils linux-info pax-utils toolchain-funcs wxwidgets
+
+DESCRIPTION="Disk encryption with strong security based on TrueCrypt"
+HOMEPAGE="https://www.veracrypt.fr/en/Home.html"
+SRC_URI="https://github.com/${PN}/VeraCrypt/archive/VeraCrypt_1.24-Update2.tar.gz -> ${P}.tar.gz"
+
+# The modules not linked against in Linux include (but not limited to):
+# libzip, chacha-xmm, chacha256, chachaRng, rdrand, t1ha2
+# Tested by actually removing the source files and performing a build
+# For this reason, we don't have to worry about their licenses
+LICENSE="Apache-2.0 BSD truecrypt-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+asm cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc X"
+RESTRICT="bindist mirror"
+
+WX_GTK_VER="3.0-gtk3"
+
+RDEPEND="
+ sys-fs/lvm2
+ sys-fs/fuse:0
+ x11-libs/wxGTK:${WX_GTK_VER}[X?]
+ app-admin/sudo
+ dev-libs/pkcs11-helper
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ asm? ( dev-lang/yasm )
+"
+
+S="${WORKDIR}/VeraCrypt-VeraCrypt_1.24-Update2/src"
+
+pkg_setup() {
+ local CONFIG_CHECK="~BLK_DEV_DM ~CRYPTO ~CRYPTO_XTS ~DM_CRYPT ~FUSE_FS"
+ linux-info_pkg_setup
+
+ setup-wxwidgets
+}
+
+src_prepare() {
+ # 1.24_p2 breaks the compilation against wxGTK[-X]
+ # See: https://github.com/veracrypt/VeraCrypt/issues/531
+ eapply -p2 "${FILESDIR}"/${PN}-1.24_p2-revert-wxwidgets-breakage.patch
+ eapply -p2 "${FILESDIR}"/${PN}-1.24-no-gui-fix.patch
+ default
+}
+
+src_compile() {
+ local TC_EXTRA_CFLAGS="${CFLAGS}"
+ local TC_EXTRA_CXXFLAGS="${CXXFLAGS}"
+ local myemakeargs=(
+ NOSTRIP=1
+ NOTEST=1
+ VERBOSE=1
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
+ RANLIB="$(tc-getRANLIB)"
+ TC_EXTRA_LFLAGS="${LDFLAGS}"
+ WX_CONFIG="${WX_CONFIG}"
+ $(usex X "" "NOGUI=1")
+ $(usex asm "" "NOASM=1")
+ $(usex cpu_flags_x86_sse2 "" "NOSSE2=1")
+ $(usex cpu_flags_x86_sse4_1 "SSE41=1" "")
+ $(usex cpu_flags_x86_ssse3 "SSSE3=1" "")
+ )
+
+ # We need to explicitly disable the GUI support when linking against
+ # wxwidgets, in case it was compiled with USE=X
+ if ! use X; then
+ TC_EXTRA_CFLAGS="${TC_EXTRA_CFLAGS} -DwxUSE_GUI=0"
+ TC_EXTRA_CXXFLAGS="${TC_EXTRA_CXXFLAGS} -DwxUSE_GUI=0"
+ fi
+
+ myemakeargs+=(
+ TC_EXTRA_CFLAGS="${TC_EXTRA_CFLAGS}"
+ TC_EXTRA_CXXFLAGS="${TC_EXTRA_CXXFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_test() {
+ "${S}/Main/veracrypt" --text --test || die "tests failed"
+}
+
+src_install() {
+ local DOCS=( Readme.txt )
+ local HTML_DOCS=( )
+
+ dobin Main/veracrypt
+ if use doc; then
+ DOCS+=( "${S}"/../doc/EFI-DCS )
+ docompress -x "/usr/share/doc/${PF}/EFI-DCS"
+ HTML_DOCS+=( "${S}"/../doc/html/. )
+ fi
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ if use X; then
+ local s
+ for s in 16 48 128 256; do
+ newicon -s ${s} Resources/Icons/VeraCrypt-${s}x${s}.xpm veracrypt.xpm
+ done
+ make_desktop_entry ${PN} "VeraCrypt" ${PN} "Utility;Security"
+ fi
+
+ pax-mark -m "${D%/}/usr/bin/veracrypt"
+}
+
+pkg_postinst() {
+ ewarn "VeraCrypt has a very restrictive license. Please be explicitly aware"
+ ewarn "of the limitations on redistribution of binaries or modified source."
+}