summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-03-05 18:07:25 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-03-05 18:07:25 +0200
commitaf4ea715963c943db4fd6ed197f0e0da11587dc9 (patch)
tree7eb7dcb4d134e0bccfbfe45738b8397515404007 /app-crypt/xca/xca-1.4.1.ebuild
parentsci-mathematics/cgal: Sort DEPENDs, use HTML_DOCS (diff)
downloadgentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.tar.gz
gentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.tar.bz2
gentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.zip
app-crypt/xca: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=649620 Thanks: Polynomial-C Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/xca/xca-1.4.1.ebuild')
-rw-r--r--app-crypt/xca/xca-1.4.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/xca/xca-1.4.1.ebuild b/app-crypt/xca/xca-1.4.1.ebuild
new file mode 100644
index 000000000000..aaaacc6e8049
--- /dev/null
+++ b/app-crypt/xca/xca-1.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="http://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}