summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-02-10 15:21:50 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2020-02-10 15:21:50 -0500
commit22c6be7b4053673b552006a287a6bbf5ef6c3dcb (patch)
tree78f7b5ca252bb9192fbdec6f1451b31a74235780 /app-crypt/yubikey-manager-qt
parentapp-crypt/yubikey-manager: bump to 3.1.1 (diff)
downloadgentoo-22c6be7b4053673b552006a287a6bbf5ef6c3dcb.tar.gz
gentoo-22c6be7b4053673b552006a287a6bbf5ef6c3dcb.tar.bz2
gentoo-22c6be7b4053673b552006a287a6bbf5ef6c3dcb.zip
app-crypt/yubikey-manager-qt: bump to 1.1.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager-qt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index eb96f3aee7a7..abca9d7e88f2 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1 +1,2 @@
DIST yubikey-manager-qt-1.1.3.tar.gz 13316325 BLAKE2B 765634b05fff9efdd5ec5e91e0a5de7f04144476b83f7b3ba8a0c8a1bc95ca7132f25e193afca2bec17fe377c683063a14657efc24fb047a64a8f4498c7abaed SHA512 84bcca3f74967ba8aa470b8dd6c8699ff6a93a85ce942934a1d0cd674a4c507ba297d9a5ebb40bae3476ea713965a7bb3816dad1110a045c338f070eb249f02b
+DIST yubikey-manager-qt-1.1.4.tar.gz 13318769 BLAKE2B 4ca85d8f9681f725cf9f8d547d850516c77a618c595814c8add12250677e495952229c966a2e59d449dfa33ac9c6788f6daa8494702137eab937b299f896e8dd SHA512 9e3e85a22d7be4e6ab30b3fd068fcc3406348d2b38f96e1ef8d693bf37edafaf8f16dc408cc9319173e871cc24d2cc4db5853ec3f8a0365221722504dc6fde04
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild
new file mode 100644
index 000000000000..6fb3d2e0e306
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit eutils qmake-utils python-single-r1
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-crypt/yubikey-manager-1.0.0[${PYTHON_MULTI_USEDEP}]
+ <app-crypt/yubikey-manager-4.0.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}