summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-07-06 12:49:28 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2017-07-06 12:49:28 -0400
commiteee8ca2f28229c5f636df6094fca70943757a905 (patch)
treeb82f7ee6b910213dc3e48b554a7cd08ec7334d87 /app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
parentapp-crypt/yubikey-manager: add missing deps for 0.3.2 #623944 (diff)
downloadgentoo-eee8ca2f28229c5f636df6094fca70943757a905.tar.gz
gentoo-eee8ca2f28229c5f636df6094fca70943757a905.tar.bz2
gentoo-eee8ca2f28229c5f636df6094fca70943757a905.zip
app-crypt/yubikey-manager: bump to 0.3.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
new file mode 100644
index 000000000000..8e88b1ec4248
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"