summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2021-03-14 15:39:28 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2021-03-14 15:55:12 -0400
commitb27a47f5a8b4e879d914cef3020302556602d09a (patch)
treeda5567625475138e35620059271659f47a62cdc9 /app-crypt/yubikey-manager
parentdev-python/fido2: remove old 0.7.3 (diff)
downloadgentoo-b27a47f5a8b4e879d914cef3020302556602d09a.tar.gz
gentoo-b27a47f5a8b4e879d914cef3020302556602d09a.tar.bz2
gentoo-b27a47f5a8b4e879d914cef3020302556602d09a.zip
app-crypt/yubikey-manager: bump to 4.0.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 4661b37fc7bf..78276c7fcc30 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1 +1,2 @@
DIST yubikey-manager-3.1.2.tar.gz 116728 BLAKE2B 35b592a26bbe1c2a1c81ddbc5fd5de2693b01dbadd04dd317baa14e5f9c5556ff8622bc36e31983947b4eed272be16d8ae1d55c6e30fe5532c20605c784411c5 SHA512 e7ad46536fae0476ae7ea4d7115ba9ddb0fe158fcd1e1d548524860b2033996f5487f9c948df85586d5b7ea690b51ad8d5b43261a56aa8820940226e0b18acaa
+DIST yubikey-manager-4.0.0.tar.gz 137438 BLAKE2B df50113ed46c531032785ceb95ee130a2440f88677b088f70095545528cbceff55db483bc299654beb8d78b3cea94a9c8507751a090a8488cc609680167ec8d7 SHA512 f1684122a9ee8d57fa3644ecf140e39973c822dfcb7cc1d6578a2ef9b09ff9b0078e6e4ab3f0eb6522a08703d095027f9f24bc8ca6fff8b6874f7a9b5e99f1b2
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.0.ebuild
new file mode 100644
index 000000000000..46d392c70cf0
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-4.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests require non-existing package makefun
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+ readme.gentoo_create_doc
+
+ doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}