summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-15 16:15:24 +0200
committerMarek Szuba <marecki@gentoo.org>2021-09-15 16:16:21 +0200
commite240f31e34f3678811adadb9b90cd25c08cae06d (patch)
treefdddd3ba6fcdad708acdf7e6f9089f4140f33603 /app-crypt/yubikey-manager
parentmail-mta/protonmail-bridge: add 1.8.9 (diff)
downloadgentoo-e240f31e34f3678811adadb9b90cd25c08cae06d.tar.gz
gentoo-e240f31e34f3678811adadb9b90cd25c08cae06d.tar.bz2
gentoo-e240f31e34f3678811adadb9b90cd25c08cae06d.zip
app-crypt/yubikey-manager: add 4.0.7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 6e3c513aef98..e2a0f0c60d49 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,3 +1,4 @@
DIST yubikey-manager-3.1.2.tar.gz 116728 BLAKE2B 35b592a26bbe1c2a1c81ddbc5fd5de2693b01dbadd04dd317baa14e5f9c5556ff8622bc36e31983947b4eed272be16d8ae1d55c6e30fe5532c20605c784411c5 SHA512 e7ad46536fae0476ae7ea4d7115ba9ddb0fe158fcd1e1d548524860b2033996f5487f9c948df85586d5b7ea690b51ad8d5b43261a56aa8820940226e0b18acaa
DIST yubikey-manager-4.0.0.tar.gz 137438 BLAKE2B df50113ed46c531032785ceb95ee130a2440f88677b088f70095545528cbceff55db483bc299654beb8d78b3cea94a9c8507751a090a8488cc609680167ec8d7 SHA512 f1684122a9ee8d57fa3644ecf140e39973c822dfcb7cc1d6578a2ef9b09ff9b0078e6e4ab3f0eb6522a08703d095027f9f24bc8ca6fff8b6874f7a9b5e99f1b2
DIST yubikey-manager-4.0.5.tar.gz 142197 BLAKE2B c48a9c6ae5f2d54b24888b750c6263eb501e68be56beb9fb964e8b9ea5131a608786b2e67d0d092ebcfacb15b09cae3eec19f4271893ac77eba70eee28b6d06d SHA512 f8bddf3121c0c509fcacb56500f1c1885354aff5c00b3347d9ca84cdf1df65276ed744209d9653474909b6cba7595bc5529cd4b37ec34c35d2d2c3cf2ff850de
+DIST yubikey-manager-4.0.7.tar.gz 143622 BLAKE2B 1ea768b4b95a65dc2cbc34f1e796a1012b534495154f475c7deb9ec7dbc807ff688d864abba8001752d3717034acbf39cd1cb17f147842fc38d27a83cb8c8ddc SHA512 7ba11488cddcc7d4bb15e673b7d8d82d8e85c52d8a4a3a13c6681cc494ecf33b88eb54556785783e6ec458292f155668bac0bb3a38a2df1702a24f623f8b084e
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.7.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.7.ebuild
new file mode 100644
index 000000000000..6409b45b5cd3
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-4.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+RESTRICT="test" # Tests require non-existing package makefun
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}