summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-07 01:07:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-07 01:09:28 -0600
commit1d6aebccdfc3067fd39fc98d02b328c9c8826110 (patch)
treedc3c27836e30b00dd059ace61d9b4ed5f97215bf /app-crypt
parentapp-crypt/certbot-apache: 1.11.0 bump (diff)
downloadgentoo-1d6aebccdfc3067fd39fc98d02b328c9c8826110.tar.gz
gentoo-1d6aebccdfc3067fd39fc98d02b328c9c8826110.tar.bz2
gentoo-1d6aebccdfc3067fd39fc98d02b328c9c8826110.zip
app-crypt/certbot-nginx: 1.11.0 bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.11.0.ebuild32
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild4
3 files changed, 35 insertions, 2 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 653ac5b25cb4..a11dafe83f7e 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.10.1.tar.gz 1416402 BLAKE2B e00ba6bf69dbf4bc91be325d4c9ba470214aeef18b4ad4ac5efbf7d077ffa9498e9cff2eff00045bc1024930f95ec56e1773c3a193a982b393caf7ee19f8ccc0 SHA512 332e92dd7d91b9774e55ef8d2c0217a57167a26d1e86d36196fc601b4abb23f40033f94112c4b4bff5f8bc54e1e32ecd68b1f01e7d67bc4fd8f7dd98ce0362cc
+DIST certbot-1.11.0.tar.gz 1419116 BLAKE2B 4749dcd897822d4e1981ef57334a493e7b729205f3ae808893ed4cab682b74c8779893378fa5cd2651b4ef681518c5aac751514104b64adfd7a17435946c46b7 SHA512 b744e44e8a7981d7b28064a2b7b5d1f47ac1ea465fa350b4f849004f38e6b3966e3118e5ebd8c1c83b9a4a065c31005c0e2cb33f75a0b04125fbe2ac17312a24
DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.11.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.11.0.ebuild
new file mode 100644
index 000000000000..d4eff10c4003
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index 383e16073c64..d4eff10c4003 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then