summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-05 19:06:11 -0500
committerYixun Lan <dlan@gentoo.org>2024-01-06 10:23:23 +0000
commit2da114edf6cb70c8e2a05a1e337330144abd21ad (patch)
tree1b26d73b41b78ad590f43cf1b0332e4838c44ee6 /app-crypt
parentdev-python/rpds-py: Stabilize 0.15.2 amd64, #921485 (diff)
downloadgentoo-2da114edf6cb70c8e2a05a1e337330144abd21ad.tar.gz
gentoo-2da114edf6cb70c8e2a05a1e337330144abd21ad.tar.bz2
gentoo-2da114edf6cb70c8e2a05a1e337330144abd21ad.zip
app-crypt/mhash: fix compilation on GCC 14
Closes: https://bugs.gentoo.org/919700 Closes: https://github.com/gentoo/gentoo/pull/34665 Signed-off-by: Christopher Fore <csfore@posteo.net> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch13
-rw-r--r--app-crypt/mhash/mhash-0.9.9.9-r3.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch b/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch
new file mode 100644
index 000000000000..3b173f8072cb
--- /dev/null
+++ b/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/tiger.c b/lib/tiger.c
+index 8f15df4..8d28f27 100644
+--- a/lib/tiger.c
++++ b/lib/tiger.c
+@@ -254,7 +254,7 @@ void tiger_final(struct tiger_ctx *ctx)
+ register mutils_word64 i, j;
+ /* Force 64-bit alignment */
+ mutils_word64 temp_64bit[TIGER_DATASIZE/8];
+- mutils_word8 *temp = temp_64bit;
++ mutils_word8 *temp = (mutils_word8 *) temp_64bit;
+ i = ctx->index;
+
+ #if defined(WORDS_BIGENDIAN)
diff --git a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
index 59e8dcb9010e..092842a0b701 100644
--- a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}"/${P}-alignment.patch
"${FILESDIR}"/${P}-no-malloc-check.patch
"${FILESDIR}"/${P}-hmac-uaf-test.patch
+ "${FILESDIR}"/${P}-cast-temp-64bit.patch
)
DOCS=( doc/example.c doc/skid2-authentication )