summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-12-07 09:40:22 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-12-07 18:32:52 +0200
commit31d38be94f651f42df8ce08f433e290129a1f49a (patch)
treee10f8e1157d9c4b4bbcfc7644e6920a76bc0b687 /app-crypt
parentdev-php/pecl-uploadprogress: Drop old (diff)
downloadgentoo-31d38be94f651f42df8ce08f433e290129a1f49a.tar.gz
gentoo-31d38be94f651f42df8ce08f433e290129a1f49a.tar.bz2
gentoo-31d38be94f651f42df8ce08f433e290129a1f49a.zip
app-crypt/trousers: support libressl
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/trousers/files/trousers-0.3.14-libressl.patch26
-rw-r--r--app-crypt/trousers/trousers-0.3.14-r1.ebuild (renamed from app-crypt/trousers/trousers-0.3.14.ebuild)1
2 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/trousers/files/trousers-0.3.14-libressl.patch b/app-crypt/trousers/files/trousers-0.3.14-libressl.patch
new file mode 100644
index 000000000000..927626892b19
--- /dev/null
+++ b/app-crypt/trousers/files/trousers-0.3.14-libressl.patch
@@ -0,0 +1,26 @@
+From b8b1cda430270f03dc556cf9cf7d2fd478101525 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 7 Dec 2016 09:36:34 +0200
+Subject: [PATCH] tspi: support libressl
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/trspi/crypto/openssl/rsa.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/trspi/crypto/openssl/rsa.c b/src/trspi/crypto/openssl/rsa.c
+index 2b1205f..3e56015 100644
+--- a/src/trspi/crypto/openssl/rsa.c
++++ b/src/trspi/crypto/openssl/rsa.c
+@@ -38,7 +38,7 @@
+ #define DEBUG_print_openssl_errors()
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100001L
++#if OPENSSL_VERSION_NUMBER < 0x10100001L || defined(LIBRESSL_VERSION_NUMBER)
+ static int
+ RSA_set0_key(RSA *r, BIGNUM *n, BIGNUM *e, BIGNUM *d)
+ {
+--
+2.7.3
+
diff --git a/app-crypt/trousers/trousers-0.3.14.ebuild b/app-crypt/trousers/trousers-0.3.14-r1.ebuild
index 1e8be96d2240..235494ae9dfd 100644
--- a/app-crypt/trousers/trousers-0.3.14.ebuild
+++ b/app-crypt/trousers/trousers-0.3.14-r1.ebuild
@@ -29,6 +29,7 @@ RDEPEND="${CDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-0.3.13-nouseradd.patch"
+ "${FILESDIR}/${P}-libressl.patch"
)
DOCS="AUTHORS ChangeLog NICETOHAVES README TODO"