summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-30 12:50:56 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-30 13:23:27 +0100
commit350047673e92584aeb10ddeed7b986d686ae7c98 (patch)
tree156928e1d117db4f82b56c2441fd19c1fac27733 /app-crypt
parentx11-libs/gtk+: Drop old (diff)
downloadgentoo-350047673e92584aeb10ddeed7b986d686ae7c98.tar.gz
gentoo-350047673e92584aeb10ddeed7b986d686ae7c98.tar.bz2
gentoo-350047673e92584aeb10ddeed7b986d686ae7c98.zip
app-crypt/libsecret: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libsecret/Manifest1
-rw-r--r--app-crypt/libsecret/libsecret-0.18.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-crypt/libsecret/Manifest b/app-crypt/libsecret/Manifest
index 059552ff21f1..8b9c45387ec0 100644
--- a/app-crypt/libsecret/Manifest
+++ b/app-crypt/libsecret/Manifest
@@ -1 +1,2 @@
DIST libsecret-0.18.3.tar.xz 481256 SHA256 f2bf1d0c5ab4640664f3e3c7ef6b086c180e50ff415720b5e22f96750dbf84c9 SHA512 ff2cdc01f2d68eaa4e3de925616e22532aa41b489ba3da7d071eef64a11b652e78ed44447c5c161eca4aa13d7f3cfb5a6ddef67fee9e520cb58782cc0acac258 WHIRLPOOL b78eb8a3a0cdc7fecd2c74a96eeb6fab9b48f7d994b0a2b0b3e60763956426ce1aab3db3da92cbc1dfdee993a9b7b70920f863fd1859dd2fc047ce659ef5e8e0
+DIST libsecret-0.18.4.tar.xz 499132 SHA256 0f29b51698198e6999c91f4adce3119c8c457f546b133a85baea5ea9010a19ed SHA512 2350d43d8a8db77a4330bc1a8b6ac82270aee7e455373f3e433d5e35539ce5c212fea7a840b0fcf76cf6ec209eb168a64864c582b36e7ec6e1d6b9f78276dcaf WHIRLPOOL cd1952cb97459767b16765c25767c59ccbe028eb8f92c5174f49529cf3caf2c955a72d1396514507a7aced60c993d69d7ed47dbb667338908226da37e6eab1eb
diff --git a/app-crypt/libsecret/libsecret-0.18.4.ebuild b/app-crypt/libsecret/libsecret-0.18.4.ebuild
new file mode 100644
index 000000000000..bed4d00f42bd
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+PDEPEND=">=gnome-base/gnome-keyring-3
+"
+# PDEPEND to avoid circular dep (bug #547456)
+# Add ksecrets to PDEPEND when it's added to portage
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-python/mock
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gjs-1.32
+ dev-python/pygobject:3 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}