summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-10-23 16:21:48 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-10-23 16:22:03 -0400
commit3dd354ed5db5a6bdcd0d8fef1f067d8edae6dd27 (patch)
tree5f620e5468a926ee16572999ff298b3aad6bebed /app-crypt
parentwww-misc/urlwatch: remove old (diff)
downloadgentoo-3dd354ed5db5a6bdcd0d8fef1f067d8edae6dd27.tar.gz
gentoo-3dd354ed5db5a6bdcd0d8fef1f067d8edae6dd27.tar.bz2
gentoo-3dd354ed5db5a6bdcd0d8fef1f067d8edae6dd27.zip
app-crypt/hashcat: bump
fix minor qa violation Signed-off-by: Rick Farina <zerochaos@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/hashcat/Manifest1
-rw-r--r--app-crypt/hashcat/hashcat-4.2.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
index edb9c46194c6..7f927c52645c 100644
--- a/app-crypt/hashcat/Manifest
+++ b/app-crypt/hashcat/Manifest
@@ -1,2 +1,3 @@
DIST hashcat-4.1.0.tar.gz 3956136 BLAKE2B f9d6f9322e4c50ee1e156c283da1257a24f0e2cb22618cf93b8b11dd1964f6741f409429ee904412f70301e4b2381b388bcab0296a30ea3a94569efe7aaaeec6 SHA512 c9e01847c89dd8521da8734ea324c69f1e9bfef50c059e9dc29d4b947fe090405774a57ae688f907698c7d9a2d1f087b730e0a994dc5ed0d5d937a9ef950dd73
DIST hashcat-4.2.0.tar.gz 3965021 BLAKE2B ad208f2debe1e4ece893e4a277b199962aa98aab57a2e78aef1d4177dcf7fc03bf262657dfe0f51c2ae845c8ed92232de7131f909d63bdc91e9f14e0b9602bb6 SHA512 686975db24737a718b484dd84b66807dfbe9694f1832da648b3c3b9fc8b859cd5c4c4d0aebf04ae862de38656d92c989e4e9515a07bec19b3779d74350beb0bd
+DIST hashcat-4.2.1.tar.gz 3966264 BLAKE2B 2034fff6aa8724cded0c8576cb4593d90f94eaea8f932e511ed82f2576ded2ffd6f686dac484e52a9ebb3029e90845469418ac414f2edf03e3fdc3350df8766f SHA512 a2cfc7e19e82b237892bacc79ca1a62a3b2ea598e4e5f60d4e275a0c128d865945595d8f918e3bb93bf62376f11f448ff53257faa12fd051dfc64973fbb6ed1e
diff --git a/app-crypt/hashcat/hashcat-4.2.1.ebuild b/app-crypt/hashcat/hashcat-4.2.1.ebuild
new file mode 100644
index 000000000000..635db1e83444
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-4.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="video_cards_nvidia"
+DEPEND="virtual/opencl
+ video_cards_nvidia? ( >x11-drivers/nvidia-drivers-367.0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ export DOCUMENT_FOLDER="/usr/share/doc/${P}"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ #elif use vidia_cards_fglrx; then
+ # addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
+}