summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-03-08 14:54:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-03-08 14:55:11 -0600
commit3ef422b87c98df018bac8c7c4db99f4b47d5c9a8 (patch)
tree0d9912a8b06b3a94edcac2572ec6f2e3a8e926af /app-crypt
parentapp-crypt/certbot-apache: add 2.4.0 (diff)
downloadgentoo-3ef422b87c98df018bac8c7c4db99f4b47d5c9a8.tar.gz
gentoo-3ef422b87c98df018bac8c7c4db99f4b47d5c9a8.tar.bz2
gentoo-3ef422b87c98df018bac8c7c4db99f4b47d5c9a8.zip
app-crypt/certbot-nginx: add 2.4.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 5228001a982b..a530d8d5eccd 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -2,3 +2,4 @@ DIST certbot-2.1.0.tar.gz 1327451 BLAKE2B c4694622648427146574aa7c056d5d76dc3c4f
DIST certbot-2.1.1.gh.tar.gz 1327548 BLAKE2B 21ce7d88bc101147be237201d472f43ea71adafe37789b0a46d7d87b0bc0f1270044386507bc516beb658633cbaebcade06e0f7f6f833848e10660a6b0a09279 SHA512 9bd5d3259954fbf09287a74532ad73a6271ed07bac0e3593edc08662d562e8939982a92daca3eb5d6e6516ab530e15e0594124465e6f6608b004594418e34042
DIST certbot-2.2.0.gh.tar.gz 1331053 BLAKE2B 4a3e6d8b0b3b7f8537bd6b24234bad7657842ee64865bcef2701e572501640b7a2d49cf4dc62db25cda1039be2d20fb77ac6415cdcb4756fce0f96b5cb7410c6 SHA512 242bfa8e5b60c28b49457403b41421ef782b9f98f325cc423b58283fef410b33691c3ce126188b191c80fcd488fe5d51acfc5ca575c8e7c5b6b08198844bffb7
DIST certbot-2.3.0.gh.tar.gz 1335613 BLAKE2B af8ff393f92755e8e312f7596fe99abefa35c42cef6fa6688f7f3dd4a310205385fec81366df30d8edfe28d8abd3db447c9e1a3770fe31c3d45c69f04a038660 SHA512 5f52d9b0dd390fc696389a94ff897d803ee062feca50bb66972e197dcd79b0096b337cece2798557c3878903577171fd9afe1f18a4a2131ad7e6a62d0d945ebb
+DIST certbot-2.4.0.gh.tar.gz 1333159 BLAKE2B 534c7d090cc8a2b77b2dd8bd8c407409260c18e7741223a327bb240dac9685b1ca152d4a20bb0ec46d8717f89bd3de6f494019c57afe22a74db69641a3ed209e SHA512 c307c97154935a3a01b468d6e91505caba6073b4c01071c87382bdc08c892094d95d75b047047d3221b7d8018a61ce974c0f4defbfdee00b136af920fd579108
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild
new file mode 100644
index 000000000000..8d6ad2deaa37
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-nginx}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest