summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-30 22:57:10 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-30 22:57:10 +0200
commit4b116f407e82b9081464eefb9566d5c3fd2cd988 (patch)
treeb769dfdde187dcb6e86e64eb697da3333c25c6c1 /app-crypt
parentapp-crypt/libnitrokey: Update live ebuild (diff)
downloadgentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.tar.gz
gentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.tar.bz2
gentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.zip
app-crypt/libnitrokey: Version bump to 3.5
Bug: https://bugs.gentoo.org/686460 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libnitrokey/Manifest1
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
index 6579ce86131d..800ed44bbad8 100644
--- a/app-crypt/libnitrokey/Manifest
+++ b/app-crypt/libnitrokey/Manifest
@@ -1 +1,2 @@
DIST libnitrokey-3.3.tar.gz 76581 BLAKE2B 1a662fb94184355dc5cae2f8e3109fc82a96aed06c726e04c4fcfef3aef0423150ac1f4647e4bf3585de7805e70cd67534d72f1255c9f80b57afa2aec36fc9d3 SHA512 fe3b6c7bdeb78f736fe7aa7475880a293c516119ac049ff47ddbaba626f2d70addee4d0cd3a38ea706b94717f51c4fb56f687d5a9bb9f10895836c5adc98b11b
+DIST libnitrokey-3.5.tar.gz 94356 BLAKE2B 9e53213f309e903d26e0e8e01ab213d6bc42c5b8d720e4b19f27adb607f20ad0c6e1707bf7b55c525efbd6a4fbf7b9c87983decf6b05dab7d03701ae0ea8277f SHA512 d2a95071e92d839c8cde4ac1435158bb469c25662f2988a4e824dbc0dfe83af841e6d04589293deddd77746dbec17b30c50fab69af58cc727ed5e0f2dbd0b5e7
diff --git a/app-crypt/libnitrokey/libnitrokey-3.5.ebuild b/app-crypt/libnitrokey/libnitrokey-3.5.ebuild
new file mode 100644
index 000000000000..d3474ddf0dc0
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils udev
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/catch-2.5.0:0 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}