summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-10-03 11:57:53 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-10-03 12:11:00 -0400
commit4ba63f4e09cc6f6ec220ccae25c6d92b39268e88 (patch)
tree52083b7d72deab2bdb4e2df662cdd62c75dae884 /app-crypt
parentwww-client/firefox: drop unused USE-flag descriptions from metadata.xml (diff)
downloadgentoo-4ba63f4e09cc6f6ec220ccae25c6d92b39268e88.tar.gz
gentoo-4ba63f4e09cc6f6ec220ccae25c6d92b39268e88.tar.bz2
gentoo-4ba63f4e09cc6f6ec220ccae25c6d92b39268e88.zip
app-crypt/hashcat-bin: remove in favor of app-crypt/hashcat
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/hashcat-bin/Manifest1
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild111
-rw-r--r--app-crypt/hashcat-bin/metadata.xml12
3 files changed, 0 insertions, 124 deletions
diff --git a/app-crypt/hashcat-bin/Manifest b/app-crypt/hashcat-bin/Manifest
deleted file mode 100644
index e9ce143a52c4..000000000000
--- a/app-crypt/hashcat-bin/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST hashcat-0.49.7z 2423049 SHA256 02ca88393ecf33aaa0905592ca71e90671338c9540f212b3ad0f4666a93b406d SHA512 3e51a803c87de4f659ad3f72337234392140cd714a40eb221cb7697aa6f8df4da92ed7a7852deae5fdf36439c46fe4eaa312ed45a72dedbf13eaa6d9767e95bb WHIRLPOOL 5cbf4b4bca8371a47c5349a0e4ab825e7401a2363558eeeea9942d0652b133cc9fc11229e6ea676fbd6a179864abadfdfa5bb16a4fb9387ea74111d3ccda4bff
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild
deleted file mode 100644
index 0e505aba9bb8..000000000000
--- a/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MY_P="hashcat-${PV}"
-
-inherit eutils pax-utils
-DESCRIPTION="An multi-threaded multihash cracker"
-HOMEPAGE="http://hashcat.net/hashcat/"
-
-SRC_URI="http://hashcat.net/files/${MY_P}.7z"
-
-#license applies to this version per http://hashcat.net/forum/thread-1348.html
-LICENSE="hashcat"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
-
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/p7zip"
-
-S="${WORKDIR}/${MY_P}"
-
-RESTRICT="strip"
-QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
- opt/${PN}/hashcat-cli64.app"
-
-has_xop() {
- echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __XOP__ 1"
-}
-
-has_avx() {
- echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __AVX__ 1"
-}
-
-src_install() {
- dodoc docs/*
- rm -r *.exe docs || die
- use x86 || { rm hashcat-cli32.bin || die; }
- use amd64 || { rm hashcat-cli64.bin || die; }
- use x64-macos || { rm hashcat-cli64.app || die; }
- has_avx || { rm hashcat-cliAVX.bin || die; }
- has_xop || { rm hashcat-cliXOP.bin || die; }
-
- #I assume this is needed but I didn't check
- pax-mark m hashcat-cli*.bin
-
- insinto /opt/${PN}
- doins -r "${S}"/*
-
- dodir /opt/bin
- if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
- then
- fperms +x /opt/${PN}/hashcat-cli32.bin
- cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
- #! /bin/sh
- cd "${EPREFIX}"/opt/${PN}
- echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
- exec ./hashcat-cli32.bin \$@
- EOF
- fperms +x /opt/bin/hashcat-cli32.bin
- fi
- if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
- then
- fperms +x /opt/${PN}/hashcat-cli64.bin
- cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
- #! /bin/sh
- cd "${EPREFIX}"/opt/${PN}
- echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
- exec ./hashcat-cli64.bin \$@
- EOF
- fperms +x /opt/bin/hashcat-cli64.bin
- fi
- if [ -f "${ED}"/opt/${PN}/hashcat-cliAVX.bin ]
- then
- fperms +x /opt/${PN}/hashcat-cliAVX.bin
- cat <<-EOF > "${ED}"/opt/bin/hashcat-cliAVX.bin
- #! /bin/sh
- cd "${EPREFIX}"/opt/${PN}
- echo "Warning: hashcat-cliAVX.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
- exec ./hashcat-cliAVX.bin \$@
- EOF
- fperms +x /opt/bin/hashcat-cliAVX.bin
- fi
- if [ -f "${ED}"/opt/${PN}/hashcat-cliXOP.bin ]
- then
- fperms +x /opt/${PN}/hashcat-cliXOP.bin
- cat <<-EOF > "${ED}"/opt/bin/hashcat-cliXOP.bin
- #! /bin/sh
- cd "${EPREFIX}"/opt/${PN}
- echo "Warning: hashcat-cliXOP.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
- exec ./hashcat-cliXOP.bin \$@
- EOF
- fperms +x /opt/bin/hashcat-cliXOP.bin
- fi
- if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
- then
- fperms +x /opt/${PN}/hashcat-cli64.app
- cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
- #! /bin/sh
- cd "${EPREFIX}"/opt/${PN}
- echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
- exec ./hashcat-cli64.app \$@
- EOF
- fperms +x /opt/bin/hashcat-cli64.app
- fi
-}
diff --git a/app-crypt/hashcat-bin/metadata.xml b/app-crypt/hashcat-bin/metadata.xml
deleted file mode 100644
index 38ec8cc659e2..000000000000
--- a/app-crypt/hashcat-bin/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-<email>zerochaos@gentoo.org</email>
-<name>Rick Farina</name>
-</maintainer>
-<maintainer type="project">
-<email>crypto@gentoo.org</email>
-<name>Crypto</name>
-</maintainer>
-</pkgmetadata>