summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2019-11-02 19:56:21 -0500
committerJoonas Niilola <juippis@gentoo.org>2019-12-08 10:41:07 +0200
commit51c5f040cb0907561ef0e93c62c939a40d0e38fa (patch)
tree6428c74ac343c4d58290f7be2700c301fac146a1 /app-crypt
parentapp-crypt/trousers: Implement GLEP 81 (diff)
downloadgentoo-51c5f040cb0907561ef0e93c62c939a40d0e38fa.tar.gz
gentoo-51c5f040cb0907561ef0e93c62c939a40d0e38fa.tar.bz2
gentoo-51c5f040cb0907561ef0e93c62c939a40d0e38fa.zip
app-crypt/tpm2-abrmd: Implement GLEP 81
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1-r1.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..535dcd41a597
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="TPM2 Access Broker & Resource Manager"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/dbus:=
+ dev-libs/glib:=
+ app-crypt/tpm2-tss:="
+DEPEND="${RDEPEND}
+ acct-group/tss
+ acct-user/tss
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
+ dev-util/gdbus-codegen"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d" \
+ --with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
+ --with-systemdpresetdisable \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}