summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-05-12 14:57:55 +0200
committerCraig Andrews <candrews@gentoo.org>2020-06-10 11:54:51 -0400
commit5adab2445e1be76888839e716a70da4faad14df9 (patch)
tree19256a0f84d2b4200a06ade58a672b28b46b2c56 /app-crypt
parentnet-dns/knot: drop olds (diff)
downloadgentoo-5adab2445e1be76888839e716a70da4faad14df9.tar.gz
gentoo-5adab2445e1be76888839e716a70da4faad14df9.tar.bz2
gentoo-5adab2445e1be76888839e716a70da4faad14df9.zip
app-crypt/moolticute: bump to 0.43.19
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/15763 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.43.19.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 69cb626a09a5..9081af12e7f8 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
+DIST moolticute-0.43.19.tar.gz 5675421 BLAKE2B 8fbe68a86978970768870ac334c38b5cd532e97cb29e03975d6700a98074c51959747c35dee528275b41ef08cf42817f69337c8b93b8c2554729754d4ee818dd SHA512 fb343411854490f8e9bf937728889fc329d2f90274a34bafebacf711b02b3ff04ecad34480b786a59fda07a50f12f572b58fd2c397d46b63dc76df9228ad8711
DIST moolticute-0.43.3.tar.gz 5667511 BLAKE2B 7509a7e84979a4bd4d36728f67b9d4cdf5df74255f4f8091a647d2d7c9a3e6dc2ef1c72fe1cadcdab47ac99a7a682287c629e0e077c031ad27acde66c53ceb6d SHA512 4ea61da5068079e01ba6e6adacc87714f3fb28a2f231fad3359d88c8697b0a804005bf73b5ca9c3e48acb9cf72b21a3791752c8d747869b48b02c1b651a92f19
diff --git a/app-crypt/moolticute/moolticute-0.43.19.ebuild b/app-crypt/moolticute/moolticute-0.43.19.ebuild
new file mode 100644
index 000000000000..b4fd0cdb9d53
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.43.19.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit xdg-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ dev-qt/qtdbus:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+BDEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}