summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 19:32:07 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 19:40:48 +0300
commit67d70633119f9edce686d0233fded6db1423e8d5 (patch)
tree14627f7b985f5fac248eda4d526ba706ba6b5996 /app-crypt
parentapp-crypt/easy-rsa: remove libressl support (diff)
downloadgentoo-67d70633119f9edce686d0233fded6db1423e8d5.tar.gz
gentoo-67d70633119f9edce686d0233fded6db1423e8d5.tar.bz2
gentoo-67d70633119f9edce686d0233fded6db1423e8d5.zip
app-crypt/tpm2-tools: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-4.3.0-r1.ebuild8
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild8
2 files changed, 6 insertions, 10 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.3.0-r1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.3.0-r1.ebuild
index f9edff247c56..01663f80cd57 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-4.3.0-r1.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-4.3.0-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+fapi libressl"
+IUSE="+fapi"
# Integration test are now run as part of the testing suite, which will fail
# because none of the supported TPM emulators are in Portage. In a future
@@ -21,13 +21,11 @@ RESTRICT="test"
RDEPEND="net-misc/curl:=
>=app-crypt/tpm2-tss-2.4.0:=[fapi?]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
+ dev-libs/openssl:0="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
sys-devel/autoconf-archive"
PATCHES=(
- "${FILESDIR}/${PN}-4.3.0-libressl.patch"
"${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
)
@@ -42,5 +40,5 @@ src_prepare() {
src_configure() {
econf \
$(use_enable fapi) \
- $(use_enable !libressl hardening)
+ --enable-hardening
}
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild
index 375c04e216eb..344be726c386 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.0-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+fapi libressl"
+IUSE="+fapi"
# Integration test are now run as part of the testing suite, which will fail
# because none of the supported TPM emulators are in Portage. In a future
@@ -21,13 +21,11 @@ RESTRICT="test"
RDEPEND="net-misc/curl:=
>=app-crypt/tpm2-tss-3.0.1:=[fapi?]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
+ dev-libs/openssl:0="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
sys-devel/autoconf-archive"
PATCHES=(
- "${FILESDIR}/${PN}-5.0-libressl.patch"
"${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
)
@@ -42,5 +40,5 @@ src_prepare() {
src_configure() {
econf \
$(use_enable fapi) \
- $(use_enable !libressl hardening)
+ --enable-hardening
}