summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-07 15:28:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-07 15:28:55 -0500
commit72ac1fba54e865b09b47729160ff045c368c4adf (patch)
treeeb701e5ea9fe3a8381cfbca0f020a7c0b0adeb99 /app-crypt
parentapp-crypt/certbot-apache: 1.14.0 bump (diff)
downloadgentoo-72ac1fba54e865b09b47729160ff045c368c4adf.tar.gz
gentoo-72ac1fba54e865b09b47729160ff045c368c4adf.tar.bz2
gentoo-72ac1fba54e865b09b47729160ff045c368c4adf.zip
app-crypt/certbot-nginx: 1.14.0 bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.14.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 1fcaae335715..4f3c512dfcdd 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.12.0.tar.gz 1419901 BLAKE2B 0ee1059c34ed6c73d1a066d54592917d5c65a8a193034f2d158397b559d2c7278d25fd3d4f2c4e553cd1737bfd8e871e8afba70e483fc4401cfa9deca913ded0 SHA512 1fbbba6294c6cd11a7f3b3887ac8775ed6c8cacd22879f68a4e3d8fb03021357dd0f32d8c96806b4f5b922dc243e332cfb36ac966f509fba739551e23e0d20fa
DIST certbot-1.13.0.tar.gz 1426058 BLAKE2B 661aeb430e468a46362c537efd253bb581c7e94b32c67131ae951a67b14d8b6d0f806b7c66a7f60375bb5fe95c714e1b58d3c811d5e0ee21e371b1ff611f74a8 SHA512 1c88027a2259ef9cfb852dd5bd0d326de52d8d7bcec984ee50dc7e5dfe60e2ea68b50afa255b95b2cac08f51467d6584d5671f2410b112b50ce5e4312969ad48
+DIST certbot-1.14.0.tar.gz 1415709 BLAKE2B db06b380f70eb6e674d935870582489a722fb8b38fba7535a642200dd6a9d036f55742286129266556f6313e232b2a45003b17f7c34e5f7087b6ab14261a8132 SHA512 39ae44374cdbac11c544d4d3194debf4f98c8d8459138a650ab276f59c84e8c8d738bdc056d444506a326280c1f9fb84356a9a8f4fa6a138d701bdf792b817e5
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.14.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.14.0.ebuild
new file mode 100644
index 000000000000..52c50cecd71f
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"