summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-24 21:55:21 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-24 22:06:33 +0200
commit7e7ccf95143f1a6021b880e0c57c562463f53837 (patch)
tree725c71f305954657ffaba2664aeb510b3aa49c68 /app-crypt
parentapp-crypt/seahorse: Drop old (diff)
downloadgentoo-7e7ccf95143f1a6021b880e0c57c562463f53837.tar.gz
gentoo-7e7ccf95143f1a6021b880e0c57c562463f53837.tar.bz2
gentoo-7e7ccf95143f1a6021b880e0c57c562463f53837.zip
app-crypt/seahorse: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-3.20.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 05293b4af35c..4ff44a0e6f0a 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-3.18.0.tar.xz 1555384 SHA256 530c889a01c4cad25df4c9ab58ab95d24747875789bc6116bef529d60fc1b667 SHA512 76475645d1f94a99bf12c3bbbd840526ab3f1da9c6dd7c8c7fca1cca1cdb22692c44d6107ed1f0192dacb6990c1bbc5c1e0bb9a412132fbf18b302d6059cb254 WHIRLPOOL a470024c7c187f854f7458de31ce8aae6f27ff99ee44d872c2298983391e3f39a2c22e5c201927a5b303ced1a614de9729af9625b59714b6cd580890714e5b79
+DIST seahorse-3.20.0.tar.xz 1556556 SHA256 e2b07461ed54a8333e5628e9b8e517ec2b731068377bf376570aad998274c6df SHA512 a02d3da7af95256941ef065ac024bd5bfb53a026767b951fa2e26446fb0eed23707e69f72f6e8ebfa7d538823fa41411709fa2bebad4fbd662af1e81bc15ab82 WHIRLPOOL 79691f59771387af8f18fb2bbfb96a5830f41d1f538be0216d218f53ebc273fd00b1d455f595e4a70a3c5104d024d85b6ee279d416e94d93d800133179bfd47d
diff --git a/app-crypt/seahorse/seahorse-3.20.0.ebuild b/app-crypt/seahorse/seahorse-3.20.0.ebuild
new file mode 100644
index 000000000000..1e2f8f67ebc5
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.20.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="debug ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.11.91:=
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-3.4:3
+ >=app-crypt/libsecret-0.16
+ >=net-libs/libsoup-2.33.92:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-2.0.12
+
+ ldap? ( net-nds/openldap:= )
+ zeroconf? ( >=net-dns/avahi-0.6:= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.35
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+src_prepare() {
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bindir is needed due to bad macro expansion in desktop file, bug #508610
+ gnome2_src_configure \
+ --bindir=/usr/bin \
+ --enable-pgp \
+ --enable-ssh \
+ --enable-pkcs11 \
+ --enable-hkp \
+ $(use_enable debug) \
+ $(use_enable ldap) \
+ $(use_enable zeroconf sharing) \
+ VALAC=$(type -P true)
+}