summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:47:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:53:00 -0500
commit85da26d3081ff881de3ba28bbe7258a7d074651a (patch)
tree0985fa7b2a5c99d52ffcb72b99d49452a221f871 /app-crypt
parentapp-crypt/acme: 0.27.1 bump (diff)
downloadgentoo-85da26d3081ff881de3ba28bbe7258a7d074651a.tar.gz
gentoo-85da26d3081ff881de3ba28bbe7258a7d074651a.tar.bz2
gentoo-85da26d3081ff881de3ba28bbe7258a7d074651a.zip
app-crypt/certbot: 0.27.1 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.27.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index cfa1f91e16d0..9a0a2e67f070 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,3 +1,4 @@
DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
DIST certbot-0.25.1.tar.gz 1160526 BLAKE2B 2dd2196c5986d5f5fe59f711589b6c3393d9c4183febb7048eab0b85e033f81d5c7ff12d7fea3aa69585308f5a4984143e431047fee73b42b16bd49e1cd2d14f SHA512 6395baa33acb4cf9e953294ddb07694ffa1e76424e12114db8df0f64fb3f1872c3145b02d853c139183b2b708d40d236f91d356eb9ecca447f577bd725fee6e5
DIST certbot-0.26.1.tar.gz 1237273 BLAKE2B d3e1582eac16c224a361d383266000c057a825fca996776b575c152e9d7b29c3ac719dccfd7a7dc4a6adb9070f7c3b4a2fbf0e59bd6d5bf74acdfd7487c5103a SHA512 e1eaca840f020135ad329c458b25f69b622de0e886c69fe64f098a6ea468e74e69e16625c5ea5c9465d220b1de01e40a45450dc5e2aded1c474508f65863396a
+DIST certbot-0.27.1.tar.gz 1240538 BLAKE2B 3d03acc8465c5d44de99ffbee67bd75fbd7d6e5d1cb1d1a6551d14c64dd699bbd91deaf3398ea3a7c2eeb8c353650e6a06cf64c88533f4270f05d1f3381843cf SHA512 ce4edd1088e9abba89f026953e42f782c6e3ef41b11123d7faf8f1e4c230b2be5107ad70b7c6d515b6ce3d06a65ae132a37d4e41fd35f728a17ba94bb09ebb00
diff --git a/app-crypt/certbot/certbot-0.27.1.ebuild b/app-crypt/certbot/certbot-0.27.1.ebuild
new file mode 100644
index 000000000000..73cf25d06222
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.27.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-0.26.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
+ dev-python/josepy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ipdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v ${PN} || die
+}