summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-25 07:32:25 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-25 07:32:41 +0200
commit870961e6a8fd95ef89d6256a79d1fc2fcb57f736 (patch)
treeb87e23fb874f7b09140c0af6d14e70668ba94444 /app-crypt
parentdev-ruby/ffi: add 1.16.1 (diff)
downloadgentoo-870961e6a8fd95ef89d6256a79d1fc2fcb57f736.tar.gz
gentoo-870961e6a8fd95ef89d6256a79d1fc2fcb57f736.tar.bz2
gentoo-870961e6a8fd95ef89d6256a79d1fc2fcb57f736.zip
app-crypt/xca: add 2.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.5.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 278f8001cb02..09f009bb3f1e 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1,2 +1,3 @@
DIST xca-2.4.0.tar.gz 1778572 BLAKE2B 2e90ef264dc53019cc37700b37d5eb0c48904ca371ae1ce0cfe2ad61be8765951ea918d356c1f2764e73d846693a66c903cba1381df5d1a588aae8bb45f8c195 SHA512 e93e2cf9dc48ed43ee9b51e977f825d81ff08835eb4d77fcbe8f9dc8ce31c77c1da879b48c25ab535717542d1fe84faa6e46c410c116edbee02072040c59667c
DIST xca-2.4.0_p20230526.tar.gz 1818483 BLAKE2B bac990117d1d6a4f80d4ad2317653d8817c7d97e3ea4e92e6fcb6a1531eb782ead4a0504748107697be6e98816e89f33f43de1a8073394e4ead39c16dee3987e SHA512 1252a8230149b04c98dab6ec5fc7f424b6eb1552553831e1c53690fa55ce919537d20741dd9f0e9ac7495d3f80503d2b6b5f0c9322912226363e2b5feb66e416
+DIST xca-2.5.0.tar.gz 1850445 BLAKE2B e12666fc0513cd04bd61d4e182851c055c120425ad8d2fb2698396429b7afb4cc57c77be6d6cc3f63f9d49d5a179123b336d43dde57ef4a3274e7ba1a06f22f7 SHA512 8b283509849c9ac34d5250c780dc0c7a6319eb3201ae892fc2c38e5257d7db4e565e88167a687ffc1ca436068a41cd48fad59d3ecc8235678d46cf026280bd5e
diff --git a/app-crypt/xca/xca-2.5.0.ebuild b/app-crypt/xca/xca-2.5.0.ebuild
new file mode 100644
index 000000000000..67f03b0eab99
--- /dev/null
+++ b/app-crypt/xca/xca-2.5.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+#SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/chris2511/xca/archive/refs/tags/RELEASE.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/xca-RELEASE.${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qthelp:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-libs/openssl:*
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5 doc? ( dev-python/sphinx dev-python/sphinxcontrib-htmlhelp dev-python/sphinxcontrib-qthelp )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+ "${FILESDIR}/${PN}-2.4.0-man-page.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQTFIXEDVERSION=Qt5
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ dosym xca /usr/bin/xca-console
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}