summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-12-05 20:18:57 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-12-05 20:45:42 +0200
commit8a68a7e7be6ca12929f51796bd8c9576fa0bf1c0 (patch)
treebf773f21ca9a8f68aafcffb55ae7d07edea7fece /app-crypt
parentnet-libs/libkolabxml: Remove old (diff)
downloadgentoo-8a68a7e7be6ca12929f51796bd8c9576fa0bf1c0.tar.gz
gentoo-8a68a7e7be6ca12929f51796bd8c9576fa0bf1c0.tar.bz2
gentoo-8a68a7e7be6ca12929f51796bd8c9576fa0bf1c0.zip
app-crypt/trousers: version bump
Bug: 601542 Thanks: Conrad Kostecki Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/trousers/Manifest1
-rw-r--r--app-crypt/trousers/trousers-0.3.14.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/app-crypt/trousers/Manifest b/app-crypt/trousers/Manifest
index 7bb78b9d0e97..56a9e0e64c95 100644
--- a/app-crypt/trousers/Manifest
+++ b/app-crypt/trousers/Manifest
@@ -1,2 +1,3 @@
DIST trousers-0.3.10.tar.gz 1658652 SHA256 eb9569de5c66d9698f6c3303de03777b95ec72827f68b7744454bfa9227bc530 SHA512 1835246f846d20bc1b2731d68440a9ca45865fcd52ad847d95485e4b126fae8bec09feaad559c27d83e243d92b8adc3a67934bff2034b318df075842fe9df4f0 WHIRLPOOL 7a27ef57b0038178cbf384c9fdec2d2e3e58dbeb5e5bc1503d2a7058a8312df54fa72b87968554631e4b5e483ae5e8c5e0a2367346bf3ae001b523a507ceff40
DIST trousers-0.3.13.tar.gz 1371901 SHA256 bb908e4a3c88a17b247a4fc8e0fff3419d8a13170fe7bdfbe0e2c5c082a276d3 SHA512 c54407e538712f738b593707ffc6d617348d73de91dfddd9057273c2fcec26e5738e89db005d36d52596630a9d583f7fcb8cc388f597da6212891e2d79dce699 WHIRLPOOL 8099d2f01b1c64b2e92c78130c9f66766f9054a1ab557f0d6da149ca4869c9fed7ee3a26454ab50bd67069d30c758ccabb450dead1d9100ffacac9f596f6d46b
+DIST trousers-0.3.14.tar.gz 1378438 SHA256 ce50713a261d14b735ec9ccd97609f0ad5ce69540af560e8c3ce9eb5f2d28f47 SHA512 bf87f00329cf1d76a12cf6b6181fa22f90e76af3c5786e6e2db98438d2d3f0c0e05364374664173f45e3a2f6c0e2364948d0b958a7845cb23fcb340150cd9b21 WHIRLPOOL 1e1c51774fa796c706858d008651182673f7a88532cac35d010f4bd713fe50c1151e0a5a7ffb6975e8a050a1aab6edeb09d1672407025a776625c9b4f2912c88
diff --git a/app-crypt/trousers/trousers-0.3.14.ebuild b/app-crypt/trousers/trousers-0.3.14.ebuild
new file mode 100644
index 000000000000..1e8be96d2240
--- /dev/null
+++ b/app-crypt/trousers/trousers-0.3.14.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils linux-info readme.gentoo-r1 systemd user udev
+
+DESCRIPTION="An open-source TCG Software Stack (TSS) v1.1 implementation"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~x86"
+IUSE="doc libressl selinux" # gtk
+
+# gtk support presently does NOT compile.
+# gtk? ( >=x11-libs/gtk+-2 )
+
+CDEPEND=">=dev-libs/glib-2
+ !libressl? ( >=dev-libs/openssl-0.9.7:0 )
+ libressl? ( dev-libs/libressl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-tcsd )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.13-nouseradd.patch"
+)
+
+DOCS="AUTHORS ChangeLog NICETOHAVES README TODO"
+
+DOC_CONTENTS="
+ If you have problems starting tcsd, please check permissions and
+ ownership on /dev/tpm* and ~tss/system.data
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ # Check for driver (not sure it can be an rdep, because ot depends on the
+ # version of virtual/linux-sources... Is that supported by portage?)
+ linux-info_pkg_setup
+ local tpm_kernel_version tpm_kernel_present tpm_module
+ kernel_is ge 2 6 12 && tpm_kernel_version="yes"
+ if linux_config_exists; then
+ linux_chkconfig_present TCG_TPM && tpm_kernel_present="yes"
+ else
+ ewarn "No kernel configuration could be found."
+ fi
+ has_version app-crypt/tpm-emulator && tpm_module="yes"
+ if [[ -n "${tpm_kernel_present}" ]]; then
+ einfo "Good, you seem to have in-kernel TPM support."
+ elif [[ -n "${tpm_module}" ]]; then
+ einfo "Good, you seem to have TPM support with the external module."
+ if [[ -n "${tpm_kernel_version}" ]]; then
+ elog
+ elog "Note that since you have a >=2.6.12 kernel, you could use"
+ elog "the in-kernel driver instead of (CONFIG_TCG_TPM)."
+ fi
+ elif [[ -n "${tpm_kernel_version}" ]]; then
+ eerror
+ eerror "To use this package, you will have to activate TPM support"
+ eerror "in your kernel configuration. That's at least CONFIG_TCG_TPM,"
+ eerror "plus probably a chip specific driver (like CONFIG_TCG_ATMEL)."
+ eerror
+ else
+ eerror
+ eerror "To use this package, you should install a TPM driver."
+ eerror "You can have the following options:"
+ eerror " - install app-crypt/tpm-emulator"
+ eerror " - switch to a >=2.6.12 kernel and compile the kernel module"
+ eerror
+ fi
+
+ # New user/group for the daemon
+ enewgroup tss
+ enewuser tss -1 -1 /var/lib/tpm tss
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # econf --with-gui=$(usex gtk gtk openssl)
+ econf --with-gui=openssl
+}
+
+src_install() {
+ default
+ keepdir /var/lib/tpm
+ use doc && dodoc doc/*
+ newinitd "${FILESDIR}"/tcsd.initd tcsd
+ newconfd "${FILESDIR}"/tcsd.confd tcsd
+ systemd_dounit "${FILESDIR}"/tcsd.service
+ udev_dorules "${FILESDIR}"/61-trousers.rules
+ fowners tss:tss /var/lib/tpm
+ prune_libtool_files
+ readme.gentoo_create_doc
+}