summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-02 22:49:37 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-02 22:49:37 +0100
commit93fcb4e54250aab8f8fc31761120103512a8b7ca (patch)
tree40d4ec9643652bf0bd6d519c397c8b86450fafeb /app-crypt
parentapp-crypt/acme: Remove dependency on werkzeug (diff)
downloadgentoo-93fcb4e54250aab8f8fc31761120103512a8b7ca.tar.gz
gentoo-93fcb4e54250aab8f8fc31761120103512a8b7ca.tar.bz2
gentoo-93fcb4e54250aab8f8fc31761120103512a8b7ca.zip
app-crypt/letsencrypt: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/letsencrypt/Manifest1
-rw-r--r--app-crypt/letsencrypt/letsencrypt-0.4.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/letsencrypt/Manifest b/app-crypt/letsencrypt/Manifest
index 98f79196dd83..c1772941c46e 100644
--- a/app-crypt/letsencrypt/Manifest
+++ b/app-crypt/letsencrypt/Manifest
@@ -1 +1,2 @@
DIST letsencrypt-0.4.0.tar.gz 634899 SHA256 d7df1faedd6f5c1ffc26fd855350fc3a107dd9fe5c1c2aa4c340024fe807a0f3 SHA512 f04c3fa49619e4e182ec8d10c6e05045d1e0e1a146bad75d9382cbfc6663ad0726c9beb496f0251e43d0dd45d78220c57dda0be8c2d946a515ab2c9f0359a549 WHIRLPOOL 64b531b31214fa6f7460ce3288dc573d281d350fe631447de8f0f18b74d38cb374438f678e7782c5bc72019766f4fe8668a6ff5f809560d09a713fa4eb58f9f8
+DIST letsencrypt-0.4.1.tar.gz 672827 SHA256 750c4a2966ec21009e4f7d510eceb3f97f941f6c19eda8b58b7030ef8518cef9 SHA512 8b782ddf352c33c513e26bff0525932c9ab154a7a2545093be8958f851418700b449b3092fb8c4e1d45f6ededed979650c2593668a2dd1294760666702271182 WHIRLPOOL 6ba5bc2c1646880d8d24baad4311b8fd761765e7c8a2e8c5755627d31aad85634af545415098c0bbf28ef7ee9610709f7a6cf72d07ec7a11df6ef1fca6b3eb62
diff --git a/app-crypt/letsencrypt/letsencrypt-0.4.1.ebuild b/app-crypt/letsencrypt/letsencrypt-0.4.1.ebuild
new file mode 100644
index 000000000000..0ef00d4fa434
--- /dev/null
+++ b/app-crypt/letsencrypt/letsencrypt-0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}