summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-06-22 14:52:41 +0200
committerSebastian Pipping <sping@gentoo.org>2020-06-22 14:52:41 +0200
commit9bf2820ccbd9d4c92475e4cf3b7f843011b099d9 (patch)
tree5fb60f613bb710f2ab877b8abba80d8d5c52ad9f /app-crypt
parentmedia-libs/harfbuzz: Bump to version 2.6.8 (diff)
downloadgentoo-9bf2820ccbd9d4c92475e4cf3b7f843011b099d9.tar.gz
gentoo-9bf2820ccbd9d4c92475e4cf3b7f843011b099d9.tar.bz2
gentoo-9bf2820ccbd9d4c92475e4cf3b7f843011b099d9.zip
app-crypt/debian-archive-keyring: Uncompress changelog
Closes: https://bugs.gentoo.org/729142 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2019.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2019.1-r1.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2019.1-r1.ebuild
new file mode 100644
index 000000000000..bb310ba9327a
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2019.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}