summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-07-09 15:47:35 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-07-09 15:47:35 +0200
commit9d9048a3b7d15f70b82039fd01bcf8db83c4ac55 (patch)
tree7b06a6bacddfcd09a05fa72e41a96c01200fba84 /app-crypt
parentapp-crypt/acme: Rename tarball (diff)
downloadgentoo-9d9048a3b7d15f70b82039fd01bcf8db83c4ac55.tar.gz
gentoo-9d9048a3b7d15f70b82039fd01bcf8db83c4ac55.tar.bz2
gentoo-9d9048a3b7d15f70b82039fd01bcf8db83c4ac55.zip
app-crypt/certbot: Version bump to 0.8.1
Gentoo-Bug: #585256 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 2375ee53041f..549e16b7b495 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1 +1,2 @@
DIST certbot-0.6.0.tar.gz 686826 SHA256 58eaa6be4ae90af07d682296e42dbac924b5602c51002445059596313e182a09 SHA512 966fdbff13ac9651ebb5fafae86a58a45538d57a43eb6d157358bbecef4286634bb61dd13b94e0ca5b006980a35cc5fe55b4a12efdeadc2530653d844516c926 WHIRLPOOL 0bd424395b9002a04f6c900b208aea758f74e9864d75f6aa87fc30573f046c63f9791aa8bcce0a5452831192d1579e9b52fda5ed77befd6e4f361dab976d6369
+DIST certbot-0.8.1.tar.gz 698305 SHA256 1fb4834eba306a656f26257f86ed298df354cdecb1b0bde316a9d23a1e19db01 SHA512 8b21d270b5ee847086369b956b3346fdddd50ab0e4490d988e7ca535f4d4101e2859e99bc5f77ac920afd3a6a9210e407b155c89c28d282dc0544735a27e3eaa WHIRLPOOL 909a3f6f63fac84bf6fe8fb35b9aba46c06912af01d5f702eee5b6aeab49d4f2a92fa05e4f060da11ac6cbc89047e92457f626d6c82aa0de0f1127ca79924fc7
diff --git a/app-crypt/certbot/certbot-0.8.1.ebuild b/app-crypt/certbot/certbot-0.8.1.ebuild
new file mode 100644
index 000000000000..df9530cff4d0
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}