summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2018-05-31 23:09:22 +0100
committerMike Auty <ikelos@gentoo.org>2018-05-31 23:09:22 +0100
commitb2168c789622195e6e0b6e001b6d942e2149edee (patch)
treead1555ce68f12b1d486948d805dc9035ac72161b /app-crypt
parentsci-visualization/gnuplot: ppc/ppc64 stable wrt bug #655222 (diff)
downloadgentoo-b2168c789622195e6e0b6e001b6d942e2149edee.tar.gz
gentoo-b2168c789622195e6e0b6e001b6d942e2149edee.tar.bz2
gentoo-b2168c789622195e6e0b6e001b6d942e2149edee.zip
app-crypt/ophcrack: Bump to 3.8.0 (and drop ppc due to qtcharts)
dev-qt/qtcharts-5 isn't keyworded for ppc, so we've dropped ppc support until then. Fixes issue 656932. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ophcrack/Manifest1
-rw-r--r--app-crypt/ophcrack/ophcrack-3.8.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/ophcrack/Manifest b/app-crypt/ophcrack/Manifest
index ee7d083927e9..823ea2bfcb15 100644
--- a/app-crypt/ophcrack/Manifest
+++ b/app-crypt/ophcrack/Manifest
@@ -1,2 +1,3 @@
DIST ophcrack-3.6.0.tar.bz2 288830 BLAKE2B bc2782d08cb84df24b745fdf0e9723e058da614b73a8d25dfe77cfa2ce291eaf8abd83006a9a410f80bdd240eb81fc402d6d5ebd1c9b92b5a7f1785a203c0c7a SHA512 caa9090b622acac1114f5635c2c58a2c32453ae21a96fc4f424cbc197b056872c282cf9d41142e316a1ffbc9523832b8bc7355c1503c15ac8579470de407a5c9
DIST ophcrack-3.7.0.tar.bz2 294045 BLAKE2B f506d29b27b4b90eadfd4d650512aea54db4228c4c63b90827a7957b544ab59dae757fc521fe62ab3be55d97e483ddde2aea9ad08c96b77d156e863a61f26312 SHA512 27e73979ca3d733629b9b34c490488cc27140efb8b90d266f270c0b95572cf40319a3fb658c02448fc7a3b825cf05c18a69f5d91bd0656d8410a30645f8dc8c6
+DIST ophcrack-3.8.0.tar.bz2 293033 BLAKE2B f20bf79d5cafffaab0667b073e8d9dbcfbae0a16f4139b6304c3f6fc80a24f6ca673db9cd53e28ff277ec35821539f3960265aa28467795e25c45049acca3f31 SHA512 c66276b72299744d3e0c9fc14220c7f568e383bd324c1ede228bda5d51da78db817388421c9f5f8cd2f18687e7e53cfb0c65bcc0354b3d55ac16324c61f62dbd
diff --git a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
new file mode 100644
index 000000000000..9165b752e558
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eutils
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl qt5 +tables"
+
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-libs/netwib
+ qt5? ( dev-qt/qtcharts:5
+ dev-qt/qtgui:5 )"
+DEPEND="app-arch/unzip
+ virtual/pkgconfig
+ ${CDEPEND}"
+RDEPEND="tables? ( app-crypt/ophcrack-tables )
+ ${CDEPEND}"
+
+src_configure() {
+
+ local myconf
+
+ myconf="$(use_enable debug)"
+ myconf="${myconf} $(use_enable qt5 gui)"
+
+ econf ${myconf} || die "Failed to compile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed."
+
+ cd "${S}"
+ newicon src/gui/pixmaps/os.xpm ophcrack.xpm
+ make_desktop_entry "${PN}" OphCrack ophcrack
+}