summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-07 14:43:52 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-07 15:30:10 +0100
commitb99c9e80ca9e93f9aadb62f2f4eaba84850104cb (patch)
tree67caa1ff84409067fbc28c46522a319700ebd10f /app-crypt
parentapp-emulation/libspectrum: prune libtool files (diff)
downloadgentoo-b99c9e80ca9e93f9aadb62f2f4eaba84850104cb.tar.gz
gentoo-b99c9e80ca9e93f9aadb62f2f4eaba84850104cb.tar.bz2
gentoo-b99c9e80ca9e93f9aadb62f2f4eaba84850104cb.zip
app-crypt/chntpw: install sampasswd and samusrgrp
Closes: https://bugs.gentoo.org/840212 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/chntpw-140201-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/chntpw/chntpw-140201-r1.ebuild b/app-crypt/chntpw/chntpw-140201-r1.ebuild
new file mode 100644
index 000000000000..eaba55788b42
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="https://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+DOCS=(
+ HISTORY.txt
+ README.txt
+ WinReg.txt
+ regedit.txt
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-stdint.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ einstalldocs
+ dobin chntpw cpnt reged sampasswd samusrgrp
+
+ if use static; then
+ dobin {chntpw,reged,sampasswd,samusrgrp}.static
+ fi
+}