summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-09-06 15:58:08 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2017-09-06 15:58:08 -0400
commitbb6a86c09e4c206056cb39dcb31f7bac5ce003be (patch)
treef76bb6394512594008c8d656c2b42cc7bfb999dd /app-crypt
parentdev-libs/libtasn1: arm stable, bug #627014 (diff)
downloadgentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.tar.gz
gentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.tar.bz2
gentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.zip
app-crypt/yubikey-manager: bump to 0.4.4
* Version 0.4.4 (released 2017-09-06) ** OATH: Fix yet another issue with backwards compability, for adding new credentials. * Version 0.4.3 (released 2017-09-06) ** OATH: Fix issue with backwards compability, when used as a library. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 22759fba3298..83f163a09386 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,2 +1,3 @@
DIST yubikey-manager-0.3.3.tar.gz 51223 SHA256 5447c026739d33455ac8ae13ccaef2df231a28dda75ffbd62c91a7c5ce5d30b5 SHA512 ced7acb848747399d4b9f0214044dd40c38b332c2f8557485d61f2f0cb857a9f47d12df59ea6a7bded1076b5d539bc171d1dbc9fd8899699c0cb3cb65b0800d7 WHIRLPOOL f68c896cb10b72271a6f42e34baf3671bfcd9ccd69c688db5fd06fd6672d1cbd12271ccc563f400d922eaf842bd7e5d73af9cac0f725927f7efe4ac520d3790b
DIST yubikey-manager-0.4.2.tar.gz 55173 SHA256 dc2150bc84934a1d1e2423dc0d085be330c7aa41e42575cb0ead6f8bcefd6b3a SHA512 8b264997c25fe5abf5a76ead27194e88882edace8d2a10210e18a89262b6a34c72c313e2b7e382243b8ade0f4ce61967310ae603d784d38bfdaab76f5113daf5 WHIRLPOOL 140d4196304c6740b9682b01264aea83e43c60b6430f7f71ee073d7e481d36d05fa70e70ffd64b6ba93eb27fb57577fa739108fb03f4fc8170fb933338c4128a
+DIST yubikey-manager-0.4.4.tar.gz 55251 SHA256 65839d29205427b8e4ae0c358684a5880eb5a52caff50943a6ca9fdaa4f782fb SHA512 bb61aebffa33507f3c2e6c37acb088c134db543dd19bd67995b98b78fdb0be2a5edfc0de7ad8681821699bb74aa0417a1dd971cdc2cf3e765290da51e33f37f0 WHIRLPOOL 9e70c755ae1c753fb2b14ccb05a82e54139dd01940e3fd7ce6060de9f163902d4af1356e91ff4709e405db009b4e44dbae3c71d549cf5fb28e2b16b9e515ecf8
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild
new file mode 100644
index 000000000000..d5ad29c57862
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test" # Testing requires RSA keys which are not present in the tarball
+
+RDEPEND="
+ app-crypt/libu2f-host
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"