summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-11-08 10:27:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-11-08 10:27:56 -0600
commitc6fbea2e376aa9c5bd460944a7823a1dee16a17d (patch)
treeff24d0bf0ebffae7f9c735fdd0d7c0b9f58b48a6 /app-crypt
parentapp-crypt/certbot-apache: 0.28.0 bump (diff)
downloadgentoo-c6fbea2e376aa9c5bd460944a7823a1dee16a17d.tar.gz
gentoo-c6fbea2e376aa9c5bd460944a7823a1dee16a17d.tar.bz2
gentoo-c6fbea2e376aa9c5bd460944a7823a1dee16a17d.zip
app-crypt/certbot-nginx: 0.28.0 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.28.0.ebuild34
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index bbe5887ecd5c..49e4ebc13dc2 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.25.1.tar.gz 1160526 BLAKE2B 2dd2196c5986d5f5fe59f711589b6c3393d9c4183febb7048eab0b85e033f81d5c7ff12d7fea3aa69585308f5a4984143e431047fee73b42b16bd49e1cd2d14f SHA512 6395baa33acb4cf9e953294ddb07694ffa1e76424e12114db8df0f64fb3f1872c3145b02d853c139183b2b708d40d236f91d356eb9ecca447f577bd725fee6e5
DIST certbot-0.27.1.tar.gz 1240538 BLAKE2B 3d03acc8465c5d44de99ffbee67bd75fbd7d6e5d1cb1d1a6551d14c64dd699bbd91deaf3398ea3a7c2eeb8c353650e6a06cf64c88533f4270f05d1f3381843cf SHA512 ce4edd1088e9abba89f026953e42f782c6e3ef41b11123d7faf8f1e4c230b2be5107ad70b7c6d515b6ce3d06a65ae132a37d4e41fd35f728a17ba94bb09ebb00
+DIST certbot-0.28.0.tar.gz 1253582 BLAKE2B f97a195afacd279b1dfc2d62ea45ae43dfd2d160f148200dd0756eda1c75561a6b1326a346f84c666c8409d339bc4341106ed4cfc684a7d868b6e1e10707ef78 SHA512 07c9bbad52acebc60e48d79619e4f12818d67c3b0f41ffa4fcd02098fb9da245e4006418f54c51c2e4bb9aaa01a21f7a083c9eb092f533e6676ed75ae8667a54
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.28.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.28.0.ebuild
new file mode 100644
index 000000000000..760abf28a407
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.28.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.26.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index bda8ab5ae6d7..760abf28a407 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,7 +26,7 @@ IUSE=""
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
>=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
- >=app-crypt/acme-0.25.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.26.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]