summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-08-12 13:55:59 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2015-08-12 13:56:23 +0300
commitcab74bcc45de089d851c5000f1ca40a2c29254c6 (patch)
tree7f5965644d394470f8c9c2f2ea4cab45f1482565 /app-crypt
parentwww-plugins/adobe-flash: x86 stable wrt bug #557342 (diff)
downloadgentoo-cab74bcc45de089d851c5000f1ca40a2c29254c6.tar.gz
gentoo-cab74bcc45de089d851c5000f1ca40a2c29254c6.tar.bz2
gentoo-cab74bcc45de089d851c5000f1ca40a2c29254c6.zip
app-crypt/xca: version bump
thanks to Jesse Adelman. Bug: 557326 Package-Manager: portage-2.2.20
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-1.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 48478d93b6df..855de8a88557 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1 +1,2 @@
DIST xca-1.1.0.tar.gz 854925 SHA256 997b62b523f6581f0d96a5f5ba2fa31dcdd2b3cf1ffe924f5c69a931b0dd44df SHA512 c22a594c61f63c71e8bc7c38ccdfabe05903a33bf5116630ca4c5072b725e551a128b10f624d01a464695d739fb9d77a510b3ced99fedc5d5378cb5fd563d954 WHIRLPOOL 1b58ec3dce44e0eb101265f7b1e68695ea2121c795f7d5f6a5349c812469c50f618ce34a5985991432b49a910b2c34fd3eb8e88ac735078a6e063801f1731be0
+DIST xca-1.3.0.tar.gz 883772 SHA256 ef5b6e4ed93abb02eb53925edd222bfeb5c26a3b0698af90a416d8e92869414c SHA512 af537154a26fbb8749034b8aa79d0379e5e2567ea2b4c82c8a2f77b0fec7017d01aa0974d013f0d84eb52f2dc18994b29890d9ab63939c91aa9e316f6ef93685 WHIRLPOOL 19ce637f6794b00f7fbc363263768a8b651a21d9dd564ec7ba05fc9c729240ae8edc9d323b899b3641f9bf757b325a77c11a84848606dfe5dec839678a2c0314
diff --git a/app-crypt/xca/xca-1.3.0.ebuild b/app-crypt/xca/xca-1.3.0.ebuild
new file mode 100644
index 000000000000..97ae58bc6af5
--- /dev/null
+++ b/app-crypt/xca/xca-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://xca.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist"
+
+RDEPEND=">=dev-libs/openssl-0.9.8:*[bindist=]
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-desktop.patch
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+
+ insinto /etc/xca
+ doins misc/*.txt
+}