summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-10-02 15:17:05 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-10-02 15:19:50 -0400
commitd0235a29f2ffff8a6baf381b3fd574fa8ba66ea2 (patch)
treed9aedc46bafc165d8e810237bd2c6bfcedc290c8 /app-crypt
parentapp-crypt/yubikey-manager-qt: fix missing dep (diff)
downloadgentoo-d0235a29f2ffff8a6baf381b3fd574fa8ba66ea2.tar.gz
gentoo-d0235a29f2ffff8a6baf381b3fd574fa8ba66ea2.tar.bz2
gentoo-d0235a29f2ffff8a6baf381b3fd574fa8ba66ea2.zip
app-crypt/yubikey-manager: bump
Signed-off-by: Rick Farina <zerochaos@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-1.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index b4fa80000f94..c6c6e839a6f7 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -6,3 +6,4 @@ DIST yubikey-manager-0.6.0.tar.gz 77823 BLAKE2B 37d9a7e72135ba859521f209896c4742
DIST yubikey-manager-0.7.0.tar.gz 83385 BLAKE2B cd0c440f8ce81549e52dd8e546d82678c19d95d2257c878b48d69719031317943bcca4ee713c03ca8f3fa1de4363df629b09b005955a1217adb2dc5ce89400aa SHA512 0fec23dafd2502a1508648fc96f1dcc873eaf3ad089f87b1afd94b35391513ad3a799985fcbc201c2fb4a3a3e473d24483c04a6862117d211c4cb6b294f74be0
DIST yubikey-manager-0.7.1-test-files.tar.xz 9756 BLAKE2B 5a2e2a2a58d04c8f9954c1d13d0892b4f7392785d6e83e6948e720606318860b93e70862cee0ee7f987c14c3fa49bb7ff20cdf2a5bfc09c1f08681346428c003 SHA512 7543a9e9cfbe7f9ec02c98397f5cbd77cb307d79985a4b060176ee26605767e74d8b18d4c036ff90aed9a0232bb1382908c75e876a911c2ceb35a12666699b94
DIST yubikey-manager-0.7.1.tar.gz 71834 BLAKE2B 45b0366531c8a158b3d8ebcfa8b76d608c14dba02224d4e4962c3757446829e3dff5f5e0d0ceda67caab7c67ad0510e037770c58a50552c2c6971136cb75c806 SHA512 3e9105f1c033f9314b90cf209eb52f7879fa1ea69e9ae6dac8de0b24d7d2ff6e45b6dd530917535fa645d6eea461f5b4f23bb8deb103ffc27d1f3483cfa681c7
+DIST yubikey-manager-1.0.0.tar.gz 90653 BLAKE2B 5d8522181ad460521995d3cae63976e06a444816a24efdc83b526d50262c902c8cc76b29d43f6f07725ee714666c853b690f1dd6fe98c9409f0cc1e722ada6f5 SHA512 9fd1926bf4e2c1278a42136a05db3e5fe0b7cb3d740f601fd0a420ab851badb61c2dd165157ac5b1f47e934f771b9d0b3cca4e07d1772d0f743556d482f77c11
diff --git a/app-crypt/yubikey-manager/yubikey-manager-1.0.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-1.0.0.ebuild
new file mode 100644
index 000000000000..6857f82426ad
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-1.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~gokturk/distfiles/app-crypt/${PN}/${PN}-0.7.1-test-files.tar.xz )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/fido2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+python_test() {
+ touch "${S}"/test/__init__.py || die
+ cp -r "${WORKDIR}/files" "${S}"/test/ || die
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}