summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-17 12:10:28 -0800
committerMatt Turner <mattst88@gentoo.org>2019-11-17 12:18:04 -0800
commitd33aa78b9eec79f4f28646e51890e3f827c2d104 (patch)
tree2ba3966496d33dd4b6ed5141e941f059f507ae74 /app-crypt
parentwww-client/chromium: beta channel bump to 79.0.3945.36 (diff)
downloadgentoo-d33aa78b9eec79f4f28646e51890e3f827c2d104.tar.gz
gentoo-d33aa78b9eec79f4f28646e51890e3f827c2d104.tar.bz2
gentoo-d33aa78b9eec79f4f28646e51890e3f827c2d104.zip
app-crypt/seahorse-sharing: Version bump to 3.8.0_p20181216
Closes: https://bugs.gentoo.org/634658 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse-sharing/Manifest1
-rw-r--r--app-crypt/seahorse-sharing/seahorse-sharing-3.8.0_p20181216.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/seahorse-sharing/Manifest b/app-crypt/seahorse-sharing/Manifest
index 9f08b863408a..5a984d96488e 100644
--- a/app-crypt/seahorse-sharing/Manifest
+++ b/app-crypt/seahorse-sharing/Manifest
@@ -1 +1,2 @@
DIST seahorse-sharing-3.8.0_p20151117.tar.gz 496497 BLAKE2B 5107eb37c57d8311390399fda59d8df76f59afc6b21f107dfb1cb38dd6c68ea25bda619b1898637ff009c0e9f7617b0557b86f0194ee2c8704d804aa9f8827f9 SHA512 aa43240040f637e3c79c08f07620a92e5e76e81b758c939a8eee5bf43cdd32657f85d4b9d7440401e092ef4d556849ba0a64dc9d5a83e708bc84d9a2d7baf01c
+DIST seahorse-sharing-58db1e5b8615d74afaa5d888237ef6556368147b.tar.gz 101549 BLAKE2B c0ac487e826426c5f0a7fcfdc1078bd9b96442751821ac6597da3ffae3f5ab06b3fa4c4cf514536f9b8375f2a36529768942e6b15d6f4ea57ada543e7d95586c SHA512 6b91a8498f6065a0ddfcc53edf96dbf7720f82a73bc904ce6af18b1f52b559459e21ad9c3d550fc24730e3200c2ff9acaa9bdfe64b5bd83939b55db97ea116d9
diff --git a/app-crypt/seahorse-sharing/seahorse-sharing-3.8.0_p20181216.ebuild b/app-crypt/seahorse-sharing/seahorse-sharing-3.8.0_p20181216.ebuild
new file mode 100644
index 000000000000..6aea8f21d54c
--- /dev/null
+++ b/app-crypt/seahorse-sharing/seahorse-sharing-3.8.0_p20181216.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="yes" # disable asserts
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="Daemon for PGP public key sharing using DNS-SD and HKP"
+HOMEPAGE="https://projects.gnome.org/seahorse/"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/master/${PN}-58db1e5b8615d74afaa5d888237ef6556368147b.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ app-crypt/seahorse
+ dev-libs/glib:2
+ >=net-dns/avahi-0.6:=[dbus]
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3:3
+
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-1.4
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-3.2
+"
+# ${PN} was part of seahorse before 3.2
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-master-58db1e5b8615d74afaa5d888237ef6556368147b"
+
+src_prepare() {
+ DOCS="AUTHORS MAINTAINERS NEWS" # ChangeLog has nothing useful
+ # Do not pass --enable-tests to configure - package has no tests
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version net-dns/avahi && \
+ ! rc-config list default | grep -q "avahi-daemon" ; then
+ elog "To use ${PN}, the Avahi daemon must be running. On an OpenRC"
+ elog "system, you can start the Avahi daemon by"
+ elog "# /etc/init.d/avahi-daemon start"
+ elog "To start Avahi automatically, add it to the default runlevel:"
+ elog "# rc-update add avahi-daemon default"
+ fi
+}