summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-14 22:38:01 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-14 22:42:09 +0100
commitd5747e5b208a72652651a981a17d93508ebe173c (patch)
treeb11808595cc2a2a33029920bfb9ea0e440d89142 /app-crypt
parentnet-libs/webkit-gtk: Allow Ruby 2.3 when building 2.4.9 wrt #573714 (diff)
downloadgentoo-d5747e5b208a72652651a981a17d93508ebe173c.tar.gz
gentoo-d5747e5b208a72652651a981a17d93508ebe173c.tar.bz2
gentoo-d5747e5b208a72652651a981a17d93508ebe173c.zip
app-crypt/letsencrypt: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/letsencrypt/Manifest1
-rw-r--r--app-crypt/letsencrypt/letsencrypt-0.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/letsencrypt/Manifest b/app-crypt/letsencrypt/Manifest
index f38a307922ad..82796158f69c 100644
--- a/app-crypt/letsencrypt/Manifest
+++ b/app-crypt/letsencrypt/Manifest
@@ -1 +1,2 @@
DIST letsencrypt-0.3.0.tar.gz 627761 SHA256 a21e496ab130cf9fcaeef69019a4eef7aaf86dad84131d601db531add4f98e1a SHA512 c3fbb6d8a50ee9a84b425d16f28626cecb3b50a5149c1263d02d447854d9117c6fe4f3f2eef7f026c9d7692a499a054895a2b007da9f768c203ea91836382f36 WHIRLPOOL fa87cb033c4a45737abeb706312ac9c4fa2ab921c07cc05f1feaeb4f083727f4ba1a819035345e5dfead536d762025ef8a4eeaa6d039b64efa3350f2a64e64a5
+DIST letsencrypt-0.4.0.tar.gz 634899 SHA256 d7df1faedd6f5c1ffc26fd855350fc3a107dd9fe5c1c2aa4c340024fe807a0f3 SHA512 f04c3fa49619e4e182ec8d10c6e05045d1e0e1a146bad75d9382cbfc6663ad0726c9beb496f0251e43d0dd45d78220c57dda0be8c2d946a515ab2c9f0359a549 WHIRLPOOL 64b531b31214fa6f7460ce3288dc573d281d350fe631447de8f0f18b74d38cb374438f678e7782c5bc72019766f4fe8668a6ff5f809560d09a713fa4eb58f9f8
diff --git a/app-crypt/letsencrypt/letsencrypt-0.4.0.ebuild b/app-crypt/letsencrypt/letsencrypt-0.4.0.ebuild
new file mode 100644
index 000000000000..0ef00d4fa434
--- /dev/null
+++ b/app-crypt/letsencrypt/letsencrypt-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}