summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-04-25 14:05:18 +0200
committerSven Wegener <swegener@gentoo.org>2016-05-10 19:55:03 +0000
commitd9e1f3bd966a4b9cccc7f25ac55592b0673c7c7d (patch)
tree79db7c05272867e04c877bba7ab5802a31bf4c31 /app-crypt
parentsci-libs/exodusii: version bump (diff)
downloadgentoo-d9e1f3bd966a4b9cccc7f25ac55592b0673c7c7d.tar.gz
gentoo-d9e1f3bd966a4b9cccc7f25ac55592b0673c7c7d.tar.bz2
gentoo-d9e1f3bd966a4b9cccc7f25ac55592b0673c7c7d.zip
app-crypt/shash Fix compilation with format-security (bug #521004)
Also update EAPI to 6 Closes: https://github.com/gentoo/gentoo/pull/1345 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/shash/files/shash-0.2.6-format-security.patch28
-rw-r--r--app-crypt/shash/shash-0.2.6-r3.ebuild35
2 files changed, 63 insertions, 0 deletions
diff --git a/app-crypt/shash/files/shash-0.2.6-format-security.patch b/app-crypt/shash/files/shash-0.2.6-format-security.patch
new file mode 100644
index 000000000000..4e46639e2807
--- /dev/null
+++ b/app-crypt/shash/files/shash-0.2.6-format-security.patch
@@ -0,0 +1,28 @@
+--- shash-0.2.6/src/errors.c
++++ shash-0.2.6/src/errors.c
+@@ -4,7 +4,7 @@
+
+ void err_quit(char *errmsg)
+ {
+- fprintf(stderr, errmsg);
++ fputs(errmsg, stderr);
+ exit(-1);
+ }
+
+@@ -12,7 +12,7 @@
+ {
+
+ if (quiet < 1) {
+- fprintf(stderr, errmsg);
++ fputs(errmsg, stderr);
+ }
+
+ }
+@@ -20,6 +20,6 @@
+ void err_crit(char *errmsg)
+ {
+ if (quiet <= 2) {
+- fprintf(stderr, errmsg);
++ fputs(errmsg, stderr);
+ }
+ }
diff --git a/app-crypt/shash/shash-0.2.6-r3.ebuild b/app-crypt/shash/shash-0.2.6-r3.ebuild
new file mode 100644
index 000000000000..dfd8c98e4bc3
--- /dev/null
+++ b/app-crypt/shash/shash-0.2.6-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Generate or check digests or MACs of files"
+HOMEPAGE="http://mcrypt.hellug.gr/shash/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+DEPEND=">=app-crypt/mhash-0.8.18-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-manpage-fixes.patch
+ "${FILESDIR}"/${P}-binary-files.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog INSTALL NEWS doc/sample.shashrc doc/FORMAT
+ newbashcomp "${FILESDIR}"/shash.bash-completion ${PN}
+}