summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2015-09-29 21:25:20 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2015-09-29 21:28:00 +0200
commite1b3fca42c9882378320d3eb8538eb05f283ef05 (patch)
tree6cc2863fd7e2ad5880efef1e10c99d2f9fbc468a /app-crypt
parentdev-util/strace: drop old versions (diff)
downloadgentoo-e1b3fca42c9882378320d3eb8538eb05f283ef05.tar.gz
gentoo-e1b3fca42c9882378320d3eb8538eb05f283ef05.tar.bz2
gentoo-e1b3fca42c9882378320d3eb8538eb05f283ef05.zip
app-crypt/pinentry-0.9.6-r5: Add Qt5 support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/files/pinentry-0.9.6-add-disable-pinentry-qt5-option.patch55
-rw-r--r--app-crypt/pinentry/pinentry-0.9.6-r5.ebuild123
2 files changed, 178 insertions, 0 deletions
diff --git a/app-crypt/pinentry/files/pinentry-0.9.6-add-disable-pinentry-qt5-option.patch b/app-crypt/pinentry/files/pinentry-0.9.6-add-disable-pinentry-qt5-option.patch
new file mode 100644
index 000000000000..9522c2f4bf74
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-0.9.6-add-disable-pinentry-qt5-option.patch
@@ -0,0 +1,55 @@
+From 08ec9556c8a384ea7bb5d42d3f6aab6c2f6a8786 Mon Sep 17 00:00:00 2001
+From: Andre Heinecke <aheinecke@intevation.de>
+Date: Fri, 25 Sep 2015 15:56:55 +0200
+Subject: [PATCH] Add option to disable looking for qt5
+
+* m4/qt.m4 (FIND_QT): Add --disable-pinentry-qt5 option to
+disable qt5 support even if it is available.
+
+--
+As requested by Kristan F.
+
+GnuPG-bug-id: 2105
+---
+ m4/qt.m4 | 23 ++++++++++++++++-------
+ 1 file changed, 16 insertions(+), 7 deletions(-)
+
+diff --git a/m4/qt.m4 b/m4/qt.m4
+index 0a7ea99..0e47ec6 100644
+--- a/m4/qt.m4
++++ b/m4/qt.m4
+@@ -28,15 +28,24 @@ dnl The moc lookup code is based on libpoppler (rev. d821207)
+
+ AC_DEFUN([FIND_QT],
+ [
+- PKG_CHECK_MODULES(PINENTRY_QT,
+- Qt5Core >= 5.0.0 Qt5Gui >= 5.0.0 Qt5Widgets >= 5.0.0,
+- [have_qt5_libs="yes"],
+- [have_qt5_libs="no"])
++ AC_ARG_ENABLE(pinentry-qt5,
++ AC_HELP_STRING([--disable-pinentry-qt5],
++ [Don't use qt5 even if it is available.]),
++ enable_pinentry_qt5=$enableval,
++ enable_pinentry_qt5="try")
+
+- if "$PKG_CONFIG" --variable qt_config Qt5Core | grep -q "reduce_relocations"; then
+- PINENTRY_QT_CFLAGS="$PINENTRY_QT_CFLAGS -fpic"
+- fi
++ have_qt5_libs="no";
++
++ if test "$enable_pinentry_qt5" != "no"; then
++ PKG_CHECK_MODULES(PINENTRY_QT,
++ Qt5Core >= 5.0.0 Qt5Gui >= 5.0.0 Qt5Widgets >= 5.0.0,
++ [have_qt5_libs="yes"],
++ [have_qt5_libs="no"])
+
++ if "$PKG_CONFIG" --variable qt_config Qt5Core | grep -q "reduce_relocations"; then
++ PINENTRY_QT_CFLAGS="$PINENTRY_QT_CFLAGS -fpic"
++ fi
++ fi
+ if test "$have_qt5_libs" = "yes"; then
+ AC_CHECK_TOOL(MOC, moc)
+ AC_MSG_CHECKING([moc version])
+--
+2.1.4
+
diff --git a/app-crypt/pinentry/pinentry-0.9.6-r5.ebuild b/app-crypt/pinentry/pinentry-0.9.6-r5.ebuild
new file mode 100644
index 000000000000..6e10cf89fa45
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.9.6-r5.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools qmake-utils multilib eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="emacs gtk ncurses qt4 qt5 caps gnome-keyring static"
+
+CDEPEND="
+ >=dev-libs/libgpg-error-1.17
+ >=dev-libs/libassuan-2
+ >=dev-libs/libgcrypt-1.6.3
+ ncurses? ( sys-libs/ncurses:0= )
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? (
+ >=dev-qt/qtgui-4.4.1:4
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ caps? ( sys-libs/libcap )
+ static? ( >=sys-libs/ncurses-5.7-r5:0=[static-libs,-gpm] )
+ app-eselect/eselect-pinentry
+ gnome-keyring? ( app-crypt/libsecret )
+"
+
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+RDEPEND="
+ ${CDEPEND}
+ gnome-keyring? ( app-crypt/gcr )
+"
+
+REQUIRED_USE="
+ || ( ncurses gtk qt4 )
+ gtk? ( !static )
+ qt4? ( !static )
+ qt5? ( !static )
+ static? ( ncurses )
+ ?? ( qt4 qt5 )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
+ epatch "${FILESDIR}/${P}-add-disable-pinentry-qt5-option.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use static && append-ldflags -static
+ [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
+
+ QT_MOC=""
+ if use qt4; then
+ myconf+=( --enable-pinentry-qt
+ --disable-pinentry-qt5
+ )
+ QT_MOC="$(qt4_get_bindir)"/moc
+ # Issues finding qt on multilib systems
+ export QTLIB="$(qt4_get_libdir)"
+ elif use qt5; then
+ myconf+=( --enable-pinentry-qt )
+ QT_MOC="$(qt5_get_bindir)"/moc
+ export QTLIB="$(qt5_get_libdir)"
+ else
+ myconf+=( --disable-pinentry-qt )
+ fi
+
+ econf \
+ --enable-pinentry-tty \
+ $(use_enable emacs pinentry-emacs) \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_with caps libcap) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gnome-keyring pinentry-gnome3) \
+ "${myconf[@]}" \
+ MOC="${QT_MOC}"
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/bin/pinentry || die
+
+ if use_enable qt4 || use_enable qt5; then
+ dosym pinentry-qt /usr/bin/pinentry-qt4
+ fi
+}
+
+pkg_postinst() {
+ if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+ fi
+
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}