summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-10 16:42:21 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-10 16:43:49 -0700
commite9a9ac79a842c707793e063e2b285e59908b9178 (patch)
tree79a8b79c1ff5fdf8dbdc73414283edd948fc5adf /app-crypt
parentsys-kernel/gentoo-sources: Linux patch 5.0.15 (diff)
downloadgentoo-e9a9ac79a842c707793e063e2b285e59908b9178.tar.gz
gentoo-e9a9ac79a842c707793e063e2b285e59908b9178.tar.bz2
gentoo-e9a9ac79a842c707793e063e2b285e59908b9178.zip
app-crypt/minisign: new package
simple tool to sign files and verify signatures Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/minisign/Manifest1
-rw-r--r--app-crypt/minisign/metadata.xml17
-rw-r--r--app-crypt/minisign/minisign-0.8.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/minisign/Manifest b/app-crypt/minisign/Manifest
new file mode 100644
index 000000000000..ef15304c3b11
--- /dev/null
+++ b/app-crypt/minisign/Manifest
@@ -0,0 +1 @@
+DIST minisign-0.8.tar.gz 14045 BLAKE2B 3c0cb0ebaeeacee5f56c788a48eef8d0a324c2db2fe8f63fc16a197870c327ed2cacc618cb6422f8d7d7ef35860b58aa0a2769c851e8af9b1a7a7cd9d2ca3a07 SHA512 79bf626d0c15e39ce3bdf53600038028c0b22904b648074bf516a9ea6962c9486c41244e80637a5fbac090cce1ed9b4b3d57b8a02632646e01b43aa413cd8bd9
diff --git a/app-crypt/minisign/metadata.xml b/app-crypt/minisign/metadata.xml
new file mode 100644
index 000000000000..974452080b5e
--- /dev/null
+++ b/app-crypt/minisign/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Minisign is a dead simple tool to sign files and verify signatures.
+ It is portable, lightweight, and uses the highly secure Ed25519 public-key signature system.
+ Signature written by minisign can be verified using OpenBSD's signify tool:
+ public key files and signature files are compatible.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jedisct1/minisign</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/minisign/minisign-0.8.ebuild b/app-crypt/minisign/minisign-0.8.ebuild
new file mode 100644
index 000000000000..da90d6d5d3f4
--- /dev/null
+++ b/app-crypt/minisign/minisign-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"